ipmiutil: openssl is an optional dependency
authorPeter Korsgaard <peter@korsgaard.com>
Sun, 17 May 2015 11:42:34 +0000 (13:42 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 17 May 2015 11:42:34 +0000 (13:42 +0200)
So handle it as such (it is only needed for the lanplus functionality).

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/ipmiutil/Config.in
package/ipmiutil/ipmiutil.mk

index 250058309518242a21dd7374f9bcdcbc8d2798c8..a2a898b5c5eb1ef6780d5e7efd4cda94339f371d 100644 (file)
@@ -3,7 +3,6 @@ config BR2_PACKAGE_IPMIUTIL
        depends on BR2_USE_MMU
        depends on BR2_TOOLCHAIN_HAS_THREADS
        depends on BR2_x86_64 || BR2_i386
-       select BR2_PACKAGE_OPENSSL
        help
          The ipmiutil package provides easy-to-use utilities to view
          the SEL, perform an IPMI chassis reset, set up the IPMI LAN
index c7a8dd83be7d5ee00065f0eabf27a9c23919b4d9..f03ad9b3943532f73fae8d3f0280e8620aec34cf 100644 (file)
@@ -10,10 +10,15 @@ IPMIUTIL_LICENSE = BSD-3c
 IPMIUTIL_LICENSE_FILES = COPYING
 # We're patching configure.ac
 IPMIUTIL_AUTORECONF = YES
+
+ifeq ($(BR2_PACKAGE_OPENSSL),y)
 # tests against distro libcrypto so it might get a false positive when
 # the openssl version is old, so force it off
 # SKIP_MD2 can be used only if ALLOW_GNU is defined.
-IPMIUTIL_CONF_OPTS = CPPFLAGS="$(TARGET_CPPFLAGS) -DALLOW_GNU -DSKIP_MD2"
-IPMIUTIL_DEPENDENCIES = openssl
+IPMIUTIL_CONF_OPTS += CPPFLAGS="$(TARGET_CPPFLAGS) -DALLOW_GNU -DSKIP_MD2"
+IPMIUTIL_DEPENDENCIES += openssl
+else
+IPMIUTIL_CONF_OPTS += --disable-lanplus
+endif
 
 $(eval $(autotools-package))