systemd: rename patches to follow the new name structure
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>
Tue, 4 Nov 2014 12:24:20 +0000 (12:24 +0000)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 7 Nov 2014 13:33:40 +0000 (14:33 +0100)
Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/systemd/0001-fix-getty-unit.patch [new file with mode: 0644]
package/systemd/0002-build-sys-revert-use-of-ln-relative-option.patch [new file with mode: 0644]
package/systemd/0003-fix-am-path-libgcrypt-no-found.patch [new file with mode: 0644]
package/systemd/systemd-01-fix-getty-unit.patch [deleted file]
package/systemd/systemd-02-build-sys-revert-use-of-ln-relative-option.patch [deleted file]
package/systemd/systemd-03-fix-am-path-libgcrypt-no-found.patch [deleted file]

diff --git a/package/systemd/0001-fix-getty-unit.patch b/package/systemd/0001-fix-getty-unit.patch
new file mode 100644 (file)
index 0000000..8ec3bcf
--- /dev/null
@@ -0,0 +1,30 @@
+Prefer getty to agetty in console setup systemd units
+
+Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com>
+Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr>
+---
+
+diff -aburN systemd-212.orig/units/getty@.service.m4 systemd-212/units/getty@.service.m4
+--- systemd-212.orig/units/getty@.service.m4   2014-01-28 11:08:51.000000000 +0100
++++ systemd-212/units/getty@.service.m4        2014-03-26 11:06:27.000000000 +0100
+@@ -27,7 +27,7 @@
+ [Service]
+ # the VT is cleared by TTYVTDisallocate
+-ExecStart=-/sbin/agetty --noclear %I $TERM
++ExecStart=-/sbin/getty -L %I 115200 vt100
+ Type=idle
+ Restart=always
+ RestartSec=0
+diff -aburN systemd-212.orig/units/serial-getty@.service.m4 systemd-212/units/serial-getty@.service.m4
+--- systemd-212.orig/units/serial-getty@.service.m4    2014-03-13 18:47:24.000000000 +0100
++++ systemd-212/units/serial-getty@.service.m4 2014-03-26 11:07:01.000000000 +0100
+@@ -22,7 +22,7 @@
+ IgnoreOnIsolate=yes
+ [Service]
+-ExecStart=-/sbin/agetty --keep-baud 115200,38400,9600 %I $TERM
++ExecStart=-/sbin/getty -L %I 115200 vt100
+ Type=idle
+ Restart=always
+ RestartSec=0
diff --git a/package/systemd/0002-build-sys-revert-use-of-ln-relative-option.patch b/package/systemd/0002-build-sys-revert-use-of-ln-relative-option.patch
new file mode 100644 (file)
index 0000000..f4795b8
--- /dev/null
@@ -0,0 +1,93 @@
+From 582c9a734a0e976592946ff5b577f98551170a38 Mon Sep 17 00:00:00 2001
+From: Eric Le Bihan <eric.le.bihan.dev@free.fr>
+Date: Mon, 21 Jul 2014 11:34:38 +0200
+Subject: [PATCH 1/1] build-sys: revert use of ln relative option.
+
+Systemd build system now uses the `--relative` option from `ln(1)`.
+This option was added to GNU coreutils 8.16, which is not widely
+deployed yet by GNU/Linux distributions (not available in Debian Wheezy
+for example).
+
+Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr>
+---
+ Makefile.am  |   21 ++++++---------------
+ configure.ac |    2 --
+ 2 files changed, 6 insertions(+), 17 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index e238cde..02b39ea 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -219,8 +219,8 @@ define move-to-rootlibdir
+       if test "$(libdir)" != "$(rootlibdir)"; then \
+               $(MKDIR_P) $(DESTDIR)$(rootlibdir) && \
+               so_img_name=$$(readlink $(DESTDIR)$(libdir)/$$libname) && \
+-              rm -f $(DESTDIR)$(libdir)/$$libname && \
+-              $(LN_S) --relative -f $(DESTDIR)$(rootlibdir)/$$so_img_name $(DESTDIR)$(libdir)/$$libname && \
++              so_img_rel_target_prefix=$$(echo $(libdir) | sed 's,\(^/\|\)[^/][^/]*,..,g') && \
++              $(LN_S) -f $$so_img_rel_target_prefix$(rootlibdir)/$$so_img_name $(DESTDIR)$(libdir)/$$libname && \
+               mv $(DESTDIR)$(libdir)/$$libname.* $(DESTDIR)$(rootlibdir); \
+       fi
+ endef
+@@ -279,9 +279,9 @@ install-aliases-hook:
+       set -- $(SYSTEM_UNIT_ALIASES) && \
+               dir=$(systemunitdir) && $(install-aliases)
+       set -- $(USER_UNIT_ALIASES) && \
+-              dir=$(userunitdir) && $(install-relative-aliases)
++              dir=$(userunitdir) && $(install-aliases)
+       set -- $(GENERAL_ALIASES) && \
+-              dir= && $(install-relative-aliases)
++              dir= && $(install-aliases)
+ define install-aliases
+       while [ -n "$$1" ]; do \
+@@ -292,15 +292,6 @@ define install-aliases
+       done
+ endef
+-define install-relative-aliases
+-      while [ -n "$$1" ]; do \
+-              $(MKDIR_P) `dirname $(DESTDIR)$$dir/$$2` && \
+-              rm -f $(DESTDIR)$$dir/$$2 && \
+-              $(LN_S) --relative $(DESTDIR)$$1 $(DESTDIR)$$dir/$$2 && \
+-              shift 2 || exit $$?; \
+-      done
+-endef
+-
+ install-touch-usr-hook:
+       touch -c $(DESTDIR)/$(prefix)
+@@ -2034,7 +2025,7 @@ systemd_dbus1_generator_LDADD = \
+ dbus1-generator-install-hook:
+       $(AM_V_at)$(MKDIR_P) $(DESTDIR)$(usergeneratordir)
+       $(AM_V_RM)rm -f $(DESTDIR)$(usergeneratordir)/systemd-dbus1-generator
+-      $(AM_V_LN)$(LN_S) --relative -f $(DESTDIR)$(systemgeneratordir)/systemd-dbus1-generator $(DESTDIR)$(usergeneratordir)/systemd-dbus1-generator
++      $(AM_V_LN)$(LN_S) -f $(systemgeneratordir)/systemd-dbus1-generator $(DESTDIR)$(usergeneratordir)/systemd-dbus1-generator
+ dbus1-generator-uninstall-hook:
+       rm -f $(DESTDIR)$(usergeneratordir)/systemd-dbus1-generator
+@@ -2188,7 +2179,7 @@ systemd_bus_proxyd_LDADD = \
+ bus-proxyd-install-hook:
+       $(AM_V_at)$(MKDIR_P) $(DESTDIR)$(bindir)
+       $(AM_V_RM)rm -f $(DESTDIR)$(bindir)/systemd-stdio-bridge
+-      $(AM_V_LN)$(LN_S) --relative -f $(DESTDIR)$(rootlibexecdir)/systemd-bus-proxyd $(DESTDIR)$(bindir)/systemd-stdio-bridge
++      $(AM_V_LN)$(LN_S) -f $(rootlibexecdir)/systemd-bus-proxyd $(DESTDIR)$(bindir)/systemd-stdio-bridge
+ bus-proxyd-uninstall-hook:
+       rm -f $(DESTDIR)$(bindir)/systemd-stdio-bridge
+diff --git a/configure.ac b/configure.ac
+index ae88382..ec220af 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -96,8 +96,6 @@ AC_PATH_PROG([KMOD], [kmod], [/usr/bin/kmod], [$PATH:/usr/sbin:/sbin])
+ AC_PATH_PROG([KEXEC], [kexec], [/usr/sbin/kexec], [$PATH:/usr/sbin:/sbin])
+-AS_IF([! ln --relative --help > /dev/null 2>&1], [AC_MSG_ERROR([*** ln doesn't support --relative ***])])
+-
+ M4_DEFINES=
+ # gtkdocize greps for '^GTK_DOC_CHECK', so it needs to be on its own line
+-- 
+1.7.10.4
+
diff --git a/package/systemd/0003-fix-am-path-libgcrypt-no-found.patch b/package/systemd/0003-fix-am-path-libgcrypt-no-found.patch
new file mode 100644 (file)
index 0000000..2287ac5
--- /dev/null
@@ -0,0 +1,145 @@
+Fix AM_PATH_LIBGCRYPT not found
+
+This patch installs a copy of libgcrypt.m4 from the libgcrypt source tarball
+to systemd m4 directory.
+
+Libgcrypt uses a custom m4 macro and not pkg-config to check if the
+development files are available. Though libgcrypt support is optional in
+systemd, this macro should be available whenever autoreconf is used, otherwise
+the re-configuration will fail with:
+
+  configure.ac:616: warning: macro 'AM_PATH_LIBGCRYPT' not found in library
+
+As asking the user to install the development package of libgcrypt on the host
+machine or adding libgcrypt as a build dependency to systemd is not
+acceptable, the required file is added to the m4 directory.
+
+Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr>
+Index: systemd-213/m4/libgcrypt.m4
+===================================================================
+--- /dev/null  1970-01-01 00:00:00.000000000 +0000
++++ systemd-213/m4/libgcrypt.m4        2014-06-11 10:41:11.749305509 +0200
+@@ -0,0 +1,123 @@
++dnl Autoconf macros for libgcrypt
++dnl       Copyright (C) 2002, 2004 Free Software Foundation, Inc.
++dnl
++dnl This file is free software; as a special exception the author gives
++dnl unlimited permission to copy and/or distribute it, with or without
++dnl modifications, as long as this notice is preserved.
++dnl
++dnl This file is distributed in the hope that it will be useful, but
++dnl WITHOUT ANY WARRANTY, to the extent permitted by law; without even the
++dnl implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
++
++
++dnl AM_PATH_LIBGCRYPT([MINIMUM-VERSION,
++dnl                   [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND ]]])
++dnl Test for libgcrypt and define LIBGCRYPT_CFLAGS and LIBGCRYPT_LIBS.
++dnl MINIMUN-VERSION is a string with the version number optionalliy prefixed
++dnl with the API version to also check the API compatibility. Example:
++dnl a MINIMUN-VERSION of 1:1.2.5 won't pass the test unless the installed
++dnl version of libgcrypt is at least 1.2.5 *and* the API number is 1.  Using
++dnl this features allows to prevent build against newer versions of libgcrypt
++dnl with a changed API.
++dnl
++AC_DEFUN([AM_PATH_LIBGCRYPT],
++[ AC_ARG_WITH(libgcrypt-prefix,
++            AC_HELP_STRING([--with-libgcrypt-prefix=PFX],
++                           [prefix where LIBGCRYPT is installed (optional)]),
++     libgcrypt_config_prefix="$withval", libgcrypt_config_prefix="")
++  if test x$libgcrypt_config_prefix != x ; then
++     if test x${LIBGCRYPT_CONFIG+set} != xset ; then
++        LIBGCRYPT_CONFIG=$libgcrypt_config_prefix/bin/libgcrypt-config
++     fi
++  fi
++
++  AC_PATH_TOOL(LIBGCRYPT_CONFIG, libgcrypt-config, no)
++  tmp=ifelse([$1], ,1:1.2.0,$1)
++  if echo "$tmp" | grep ':' >/dev/null 2>/dev/null ; then
++     req_libgcrypt_api=`echo "$tmp"     | sed 's/\(.*\):\(.*\)/\1/'`
++     min_libgcrypt_version=`echo "$tmp" | sed 's/\(.*\):\(.*\)/\2/'`
++  else
++     req_libgcrypt_api=0
++     min_libgcrypt_version="$tmp"
++  fi
++
++  AC_MSG_CHECKING(for LIBGCRYPT - version >= $min_libgcrypt_version)
++  ok=no
++  if test "$LIBGCRYPT_CONFIG" != "no" ; then
++    req_major=`echo $min_libgcrypt_version | \
++               sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\)/\1/'`
++    req_minor=`echo $min_libgcrypt_version | \
++               sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\)/\2/'`
++    req_micro=`echo $min_libgcrypt_version | \
++               sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\)/\3/'`
++    libgcrypt_config_version=`$LIBGCRYPT_CONFIG --version`
++    major=`echo $libgcrypt_config_version | \
++               sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\).*/\1/'`
++    minor=`echo $libgcrypt_config_version | \
++               sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\).*/\2/'`
++    micro=`echo $libgcrypt_config_version | \
++               sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\).*/\3/'`
++    if test "$major" -gt "$req_major"; then
++        ok=yes
++    else
++        if test "$major" -eq "$req_major"; then
++            if test "$minor" -gt "$req_minor"; then
++               ok=yes
++            else
++               if test "$minor" -eq "$req_minor"; then
++                   if test "$micro" -ge "$req_micro"; then
++                     ok=yes
++                   fi
++               fi
++            fi
++        fi
++    fi
++  fi
++  if test $ok = yes; then
++    AC_MSG_RESULT([yes ($libgcrypt_config_version)])
++  else
++    AC_MSG_RESULT(no)
++  fi
++  if test $ok = yes; then
++     # If we have a recent libgcrypt, we should also check that the
++     # API is compatible
++     if test "$req_libgcrypt_api" -gt 0 ; then
++        tmp=`$LIBGCRYPT_CONFIG --api-version 2>/dev/null || echo 0`
++        if test "$tmp" -gt 0 ; then
++           AC_MSG_CHECKING([LIBGCRYPT API version])
++           if test "$req_libgcrypt_api" -eq "$tmp" ; then
++             AC_MSG_RESULT([okay])
++           else
++             ok=no
++             AC_MSG_RESULT([does not match. want=$req_libgcrypt_api got=$tmp])
++           fi
++        fi
++     fi
++  fi
++  if test $ok = yes; then
++    LIBGCRYPT_CFLAGS=`$LIBGCRYPT_CONFIG --cflags`
++    LIBGCRYPT_LIBS=`$LIBGCRYPT_CONFIG --libs`
++    ifelse([$2], , :, [$2])
++    if test x"$host" != x ; then
++      libgcrypt_config_host=`$LIBGCRYPT_CONFIG --host 2>/dev/null || echo none`
++      if test x"$libgcrypt_config_host" != xnone ; then
++        if test x"$libgcrypt_config_host" != x"$host" ; then
++  AC_MSG_WARN([[
++***
++*** The config script $LIBGCRYPT_CONFIG was
++*** built for $libgcrypt_config_host and thus may not match the
++*** used host $host.
++*** You may want to use the configure option --with-libgcrypt-prefix
++*** to specify a matching config script.
++***]])
++        fi
++      fi
++    fi
++  else
++    LIBGCRYPT_CFLAGS=""
++    LIBGCRYPT_LIBS=""
++    ifelse([$3], , :, [$3])
++  fi
++  AC_SUBST(LIBGCRYPT_CFLAGS)
++  AC_SUBST(LIBGCRYPT_LIBS)
++])
diff --git a/package/systemd/systemd-01-fix-getty-unit.patch b/package/systemd/systemd-01-fix-getty-unit.patch
deleted file mode 100644 (file)
index 8ec3bcf..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
-Prefer getty to agetty in console setup systemd units
-
-Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com>
-Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr>
----
-
-diff -aburN systemd-212.orig/units/getty@.service.m4 systemd-212/units/getty@.service.m4
---- systemd-212.orig/units/getty@.service.m4   2014-01-28 11:08:51.000000000 +0100
-+++ systemd-212/units/getty@.service.m4        2014-03-26 11:06:27.000000000 +0100
-@@ -27,7 +27,7 @@
- [Service]
- # the VT is cleared by TTYVTDisallocate
--ExecStart=-/sbin/agetty --noclear %I $TERM
-+ExecStart=-/sbin/getty -L %I 115200 vt100
- Type=idle
- Restart=always
- RestartSec=0
-diff -aburN systemd-212.orig/units/serial-getty@.service.m4 systemd-212/units/serial-getty@.service.m4
---- systemd-212.orig/units/serial-getty@.service.m4    2014-03-13 18:47:24.000000000 +0100
-+++ systemd-212/units/serial-getty@.service.m4 2014-03-26 11:07:01.000000000 +0100
-@@ -22,7 +22,7 @@
- IgnoreOnIsolate=yes
- [Service]
--ExecStart=-/sbin/agetty --keep-baud 115200,38400,9600 %I $TERM
-+ExecStart=-/sbin/getty -L %I 115200 vt100
- Type=idle
- Restart=always
- RestartSec=0
diff --git a/package/systemd/systemd-02-build-sys-revert-use-of-ln-relative-option.patch b/package/systemd/systemd-02-build-sys-revert-use-of-ln-relative-option.patch
deleted file mode 100644 (file)
index f4795b8..0000000
+++ /dev/null
@@ -1,93 +0,0 @@
-From 582c9a734a0e976592946ff5b577f98551170a38 Mon Sep 17 00:00:00 2001
-From: Eric Le Bihan <eric.le.bihan.dev@free.fr>
-Date: Mon, 21 Jul 2014 11:34:38 +0200
-Subject: [PATCH 1/1] build-sys: revert use of ln relative option.
-
-Systemd build system now uses the `--relative` option from `ln(1)`.
-This option was added to GNU coreutils 8.16, which is not widely
-deployed yet by GNU/Linux distributions (not available in Debian Wheezy
-for example).
-
-Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr>
----
- Makefile.am  |   21 ++++++---------------
- configure.ac |    2 --
- 2 files changed, 6 insertions(+), 17 deletions(-)
-
-diff --git a/Makefile.am b/Makefile.am
-index e238cde..02b39ea 100644
---- a/Makefile.am
-+++ b/Makefile.am
-@@ -219,8 +219,8 @@ define move-to-rootlibdir
-       if test "$(libdir)" != "$(rootlibdir)"; then \
-               $(MKDIR_P) $(DESTDIR)$(rootlibdir) && \
-               so_img_name=$$(readlink $(DESTDIR)$(libdir)/$$libname) && \
--              rm -f $(DESTDIR)$(libdir)/$$libname && \
--              $(LN_S) --relative -f $(DESTDIR)$(rootlibdir)/$$so_img_name $(DESTDIR)$(libdir)/$$libname && \
-+              so_img_rel_target_prefix=$$(echo $(libdir) | sed 's,\(^/\|\)[^/][^/]*,..,g') && \
-+              $(LN_S) -f $$so_img_rel_target_prefix$(rootlibdir)/$$so_img_name $(DESTDIR)$(libdir)/$$libname && \
-               mv $(DESTDIR)$(libdir)/$$libname.* $(DESTDIR)$(rootlibdir); \
-       fi
- endef
-@@ -279,9 +279,9 @@ install-aliases-hook:
-       set -- $(SYSTEM_UNIT_ALIASES) && \
-               dir=$(systemunitdir) && $(install-aliases)
-       set -- $(USER_UNIT_ALIASES) && \
--              dir=$(userunitdir) && $(install-relative-aliases)
-+              dir=$(userunitdir) && $(install-aliases)
-       set -- $(GENERAL_ALIASES) && \
--              dir= && $(install-relative-aliases)
-+              dir= && $(install-aliases)
- define install-aliases
-       while [ -n "$$1" ]; do \
-@@ -292,15 +292,6 @@ define install-aliases
-       done
- endef
--define install-relative-aliases
--      while [ -n "$$1" ]; do \
--              $(MKDIR_P) `dirname $(DESTDIR)$$dir/$$2` && \
--              rm -f $(DESTDIR)$$dir/$$2 && \
--              $(LN_S) --relative $(DESTDIR)$$1 $(DESTDIR)$$dir/$$2 && \
--              shift 2 || exit $$?; \
--      done
--endef
--
- install-touch-usr-hook:
-       touch -c $(DESTDIR)/$(prefix)
-@@ -2034,7 +2025,7 @@ systemd_dbus1_generator_LDADD = \
- dbus1-generator-install-hook:
-       $(AM_V_at)$(MKDIR_P) $(DESTDIR)$(usergeneratordir)
-       $(AM_V_RM)rm -f $(DESTDIR)$(usergeneratordir)/systemd-dbus1-generator
--      $(AM_V_LN)$(LN_S) --relative -f $(DESTDIR)$(systemgeneratordir)/systemd-dbus1-generator $(DESTDIR)$(usergeneratordir)/systemd-dbus1-generator
-+      $(AM_V_LN)$(LN_S) -f $(systemgeneratordir)/systemd-dbus1-generator $(DESTDIR)$(usergeneratordir)/systemd-dbus1-generator
- dbus1-generator-uninstall-hook:
-       rm -f $(DESTDIR)$(usergeneratordir)/systemd-dbus1-generator
-@@ -2188,7 +2179,7 @@ systemd_bus_proxyd_LDADD = \
- bus-proxyd-install-hook:
-       $(AM_V_at)$(MKDIR_P) $(DESTDIR)$(bindir)
-       $(AM_V_RM)rm -f $(DESTDIR)$(bindir)/systemd-stdio-bridge
--      $(AM_V_LN)$(LN_S) --relative -f $(DESTDIR)$(rootlibexecdir)/systemd-bus-proxyd $(DESTDIR)$(bindir)/systemd-stdio-bridge
-+      $(AM_V_LN)$(LN_S) -f $(rootlibexecdir)/systemd-bus-proxyd $(DESTDIR)$(bindir)/systemd-stdio-bridge
- bus-proxyd-uninstall-hook:
-       rm -f $(DESTDIR)$(bindir)/systemd-stdio-bridge
-diff --git a/configure.ac b/configure.ac
-index ae88382..ec220af 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -96,8 +96,6 @@ AC_PATH_PROG([KMOD], [kmod], [/usr/bin/kmod], [$PATH:/usr/sbin:/sbin])
- AC_PATH_PROG([KEXEC], [kexec], [/usr/sbin/kexec], [$PATH:/usr/sbin:/sbin])
--AS_IF([! ln --relative --help > /dev/null 2>&1], [AC_MSG_ERROR([*** ln doesn't support --relative ***])])
--
- M4_DEFINES=
- # gtkdocize greps for '^GTK_DOC_CHECK', so it needs to be on its own line
--- 
-1.7.10.4
-
diff --git a/package/systemd/systemd-03-fix-am-path-libgcrypt-no-found.patch b/package/systemd/systemd-03-fix-am-path-libgcrypt-no-found.patch
deleted file mode 100644 (file)
index 2287ac5..0000000
+++ /dev/null
@@ -1,145 +0,0 @@
-Fix AM_PATH_LIBGCRYPT not found
-
-This patch installs a copy of libgcrypt.m4 from the libgcrypt source tarball
-to systemd m4 directory.
-
-Libgcrypt uses a custom m4 macro and not pkg-config to check if the
-development files are available. Though libgcrypt support is optional in
-systemd, this macro should be available whenever autoreconf is used, otherwise
-the re-configuration will fail with:
-
-  configure.ac:616: warning: macro 'AM_PATH_LIBGCRYPT' not found in library
-
-As asking the user to install the development package of libgcrypt on the host
-machine or adding libgcrypt as a build dependency to systemd is not
-acceptable, the required file is added to the m4 directory.
-
-Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr>
-Index: systemd-213/m4/libgcrypt.m4
-===================================================================
---- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ systemd-213/m4/libgcrypt.m4        2014-06-11 10:41:11.749305509 +0200
-@@ -0,0 +1,123 @@
-+dnl Autoconf macros for libgcrypt
-+dnl       Copyright (C) 2002, 2004 Free Software Foundation, Inc.
-+dnl
-+dnl This file is free software; as a special exception the author gives
-+dnl unlimited permission to copy and/or distribute it, with or without
-+dnl modifications, as long as this notice is preserved.
-+dnl
-+dnl This file is distributed in the hope that it will be useful, but
-+dnl WITHOUT ANY WARRANTY, to the extent permitted by law; without even the
-+dnl implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
-+
-+
-+dnl AM_PATH_LIBGCRYPT([MINIMUM-VERSION,
-+dnl                   [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND ]]])
-+dnl Test for libgcrypt and define LIBGCRYPT_CFLAGS and LIBGCRYPT_LIBS.
-+dnl MINIMUN-VERSION is a string with the version number optionalliy prefixed
-+dnl with the API version to also check the API compatibility. Example:
-+dnl a MINIMUN-VERSION of 1:1.2.5 won't pass the test unless the installed
-+dnl version of libgcrypt is at least 1.2.5 *and* the API number is 1.  Using
-+dnl this features allows to prevent build against newer versions of libgcrypt
-+dnl with a changed API.
-+dnl
-+AC_DEFUN([AM_PATH_LIBGCRYPT],
-+[ AC_ARG_WITH(libgcrypt-prefix,
-+            AC_HELP_STRING([--with-libgcrypt-prefix=PFX],
-+                           [prefix where LIBGCRYPT is installed (optional)]),
-+     libgcrypt_config_prefix="$withval", libgcrypt_config_prefix="")
-+  if test x$libgcrypt_config_prefix != x ; then
-+     if test x${LIBGCRYPT_CONFIG+set} != xset ; then
-+        LIBGCRYPT_CONFIG=$libgcrypt_config_prefix/bin/libgcrypt-config
-+     fi
-+  fi
-+
-+  AC_PATH_TOOL(LIBGCRYPT_CONFIG, libgcrypt-config, no)
-+  tmp=ifelse([$1], ,1:1.2.0,$1)
-+  if echo "$tmp" | grep ':' >/dev/null 2>/dev/null ; then
-+     req_libgcrypt_api=`echo "$tmp"     | sed 's/\(.*\):\(.*\)/\1/'`
-+     min_libgcrypt_version=`echo "$tmp" | sed 's/\(.*\):\(.*\)/\2/'`
-+  else
-+     req_libgcrypt_api=0
-+     min_libgcrypt_version="$tmp"
-+  fi
-+
-+  AC_MSG_CHECKING(for LIBGCRYPT - version >= $min_libgcrypt_version)
-+  ok=no
-+  if test "$LIBGCRYPT_CONFIG" != "no" ; then
-+    req_major=`echo $min_libgcrypt_version | \
-+               sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\)/\1/'`
-+    req_minor=`echo $min_libgcrypt_version | \
-+               sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\)/\2/'`
-+    req_micro=`echo $min_libgcrypt_version | \
-+               sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\)/\3/'`
-+    libgcrypt_config_version=`$LIBGCRYPT_CONFIG --version`
-+    major=`echo $libgcrypt_config_version | \
-+               sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\).*/\1/'`
-+    minor=`echo $libgcrypt_config_version | \
-+               sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\).*/\2/'`
-+    micro=`echo $libgcrypt_config_version | \
-+               sed 's/\([[0-9]]*\)\.\([[0-9]]*\)\.\([[0-9]]*\).*/\3/'`
-+    if test "$major" -gt "$req_major"; then
-+        ok=yes
-+    else
-+        if test "$major" -eq "$req_major"; then
-+            if test "$minor" -gt "$req_minor"; then
-+               ok=yes
-+            else
-+               if test "$minor" -eq "$req_minor"; then
-+                   if test "$micro" -ge "$req_micro"; then
-+                     ok=yes
-+                   fi
-+               fi
-+            fi
-+        fi
-+    fi
-+  fi
-+  if test $ok = yes; then
-+    AC_MSG_RESULT([yes ($libgcrypt_config_version)])
-+  else
-+    AC_MSG_RESULT(no)
-+  fi
-+  if test $ok = yes; then
-+     # If we have a recent libgcrypt, we should also check that the
-+     # API is compatible
-+     if test "$req_libgcrypt_api" -gt 0 ; then
-+        tmp=`$LIBGCRYPT_CONFIG --api-version 2>/dev/null || echo 0`
-+        if test "$tmp" -gt 0 ; then
-+           AC_MSG_CHECKING([LIBGCRYPT API version])
-+           if test "$req_libgcrypt_api" -eq "$tmp" ; then
-+             AC_MSG_RESULT([okay])
-+           else
-+             ok=no
-+             AC_MSG_RESULT([does not match. want=$req_libgcrypt_api got=$tmp])
-+           fi
-+        fi
-+     fi
-+  fi
-+  if test $ok = yes; then
-+    LIBGCRYPT_CFLAGS=`$LIBGCRYPT_CONFIG --cflags`
-+    LIBGCRYPT_LIBS=`$LIBGCRYPT_CONFIG --libs`
-+    ifelse([$2], , :, [$2])
-+    if test x"$host" != x ; then
-+      libgcrypt_config_host=`$LIBGCRYPT_CONFIG --host 2>/dev/null || echo none`
-+      if test x"$libgcrypt_config_host" != xnone ; then
-+        if test x"$libgcrypt_config_host" != x"$host" ; then
-+  AC_MSG_WARN([[
-+***
-+*** The config script $LIBGCRYPT_CONFIG was
-+*** built for $libgcrypt_config_host and thus may not match the
-+*** used host $host.
-+*** You may want to use the configure option --with-libgcrypt-prefix
-+*** to specify a matching config script.
-+***]])
-+        fi
-+      fi
-+    fi
-+  else
-+    LIBGCRYPT_CFLAGS=""
-+    LIBGCRYPT_LIBS=""
-+    ifelse([$3], , :, [$3])
-+  fi
-+  AC_SUBST(LIBGCRYPT_CFLAGS)
-+  AC_SUBST(LIBGCRYPT_LIBS)
-+])