json-c: needs host-autoconf
authorBaruch Siach <baruch@tkos.co.il>
Tue, 28 Aug 2018 14:54:47 +0000 (17:54 +0300)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 28 Aug 2018 15:12:46 +0000 (17:12 +0200)
The json-c configure script uses the autoheader utility. Use the
host-autoconf provided autoheader, as this tool is not always installed
on the host.

Fixes:
http://autobuild.buildroot.net/results/030/030fddceda4f5bc6379f7bfcc405e92d2e24184a/
http://autobuild.buildroot.net/results/e48/e482f174b8124ace0690a26bb7daf073fe5fcd75/
http://autobuild.buildroot.net/results/482/4829425c38c58d9844aa07108532a93d47191d23/

Cc: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/json-c/json-c.mk

index 57d8c35dd5e380a7c495993d918e9a467a5469f1..bee57577ceec13130f0d270145a44cb4e1804467 100644 (file)
@@ -10,5 +10,9 @@ JSON_C_INSTALL_STAGING = YES
 JSON_C_LICENSE = MIT
 JSON_C_LICENSE_FILES = COPYING
 
+# configure requires autoheader
+JSON_C_DEPENDENCIES = host-autoconf
+HOST_JSON_C_DEPENDENCIES = host-autoconf
+
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))