package/opencv3: remove qt backend option
authorPeter Korsgaard <peter@korsgaard.com>
Wed, 6 Feb 2019 14:10:49 +0000 (15:10 +0100)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Wed, 6 Feb 2019 14:41:08 +0000 (15:41 +0100)
The qt backend option uses the obsolete qt4 package, which we are about to
remove, so remove the qt backend option as well.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Config.in.legacy
package/opencv3/Config.in
package/opencv3/opencv3.mk

index cdf5f989b53ff14978c790f2dfc265fcdfbae932..67e3b0dc7004020d82109027ac0bb36a817f4b35 100644 (file)
@@ -146,6 +146,12 @@ endif
 
 comment "Legacy options removed in 2019.02"
 
+config BR2_PACKAGE_OPENCV3_WITH_QT
+       bool "opencv3 qt backend option removed"
+       select BR2_LEGACY
+       help
+         The opencv3 qt backend option was removed.
+
 config BR2_PACKAGE_OPENCV_WITH_QT
        bool "opencv qt backend option removed"
        select BR2_LEGACY
index 80a297a9043ae3bee4b1f8da777ff200f3a887c0..61405a7c64a538794d4db022b1ae1c65524ce27a 100644 (file)
@@ -82,20 +82,6 @@ comment "gtk3 support needs libgtk3"
        depends on BR2_TOOLCHAIN_HAS_SYNC_4
        depends on !BR2_PACKAGE_LIBGTK3
 
-config BR2_PACKAGE_OPENCV3_WITH_QT
-       bool "qt4"
-       depends on BR2_PACKAGE_QT
-       select BR2_PACKAGE_QT_STL
-       select BR2_PACKAGE_QT_GUI_MODULE
-       select BR2_PACKAGE_QT_TEST
-       help
-         Use Qt4 with QtTest and QtGui modules and STL support, as
-         GUI toolkit.
-
-comment "qt4 support needs qt"
-       depends on BR2_USE_MMU # qt
-       depends on !BR2_PACKAGE_QT && !BR2_PACKAGE_QT5
-
 config BR2_PACKAGE_OPENCV3_WITH_QT5
        bool "qt5"
        depends on BR2_PACKAGE_QT5
@@ -108,7 +94,7 @@ config BR2_PACKAGE_OPENCV3_WITH_QT5
          components, as GUI toolkit.
 
 comment "qt5 support needs qt5"
-       depends on !BR2_PACKAGE_QT && !BR2_PACKAGE_QT5
+       depends on !BR2_PACKAGE_QT5
 
 endchoice
 
index 978f38c1439e8de07353a5d1b57dcb5044c72541..3a2594b5846dcfca7812cb930aed436a666e54a6 100644 (file)
@@ -288,18 +288,11 @@ else
 OPENCV3_CONF_OPTS += -DWITH_PNG=OFF
 endif
 
-ifeq ($(BR2_PACKAGE_OPENCV3_WITH_QT)$(BR2_PACKAGE_OPENCV3_WITH_QT5),)
-OPENCV3_CONF_OPTS += -DWITH_QT=OFF
-endif
-
-ifeq ($(BR2_PACKAGE_OPENCV3_WITH_QT),y)
-OPENCV3_CONF_OPTS += -DWITH_QT=4
-OPENCV3_DEPENDENCIES += qt
-endif
-
 ifeq ($(BR2_PACKAGE_OPENCV3_WITH_QT5),y)
 OPENCV3_CONF_OPTS += -DWITH_QT=5
 OPENCV3_DEPENDENCIES += qt5base
+else
+OPENCV3_CONF_OPTS += -DWITH_QT=OFF
 endif
 
 ifeq ($(BR2_PACKAGE_OPENCV3_WITH_TIFF),y)