package/rpcbind: Do not mark .service and .socket files executable
authorAndrey Smirnov <andrew.smirnov@gmail.com>
Wed, 23 Aug 2017 23:44:14 +0000 (16:44 -0700)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 24 Aug 2017 21:12:40 +0000 (23:12 +0200)
Do not mark .service and .socket files executable, otherwise systemd
will give us a warning about it.

Signed-off-by: Andrey Smirnov <andrew.smirnov@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/rpcbind/rpcbind.mk

index cf2e81dbbfd66b7e46a4eae2c88b07b07c1752b9..5c216afc93fbae77e3f9236dd561a06d9ae6b8de 100644 (file)
@@ -22,9 +22,9 @@ RPCBIND_CONF_OPTS += --with-systemdsystemunitdir=no
 endif
 
 define RPCBIND_INSTALL_INIT_SYSTEMD
-       $(INSTALL) -m 0755 -D package/rpcbind/rpcbind.service \
+       $(INSTALL) -m 0644 -D package/rpcbind/rpcbind.service \
                $(TARGET_DIR)/usr/lib/systemd/system/rpcbind.service
-       $(INSTALL) -m 0755 -D package/rpcbind/rpcbind.socket \
+       $(INSTALL) -m 0644 -D package/rpcbind/rpcbind.socket \
                $(TARGET_DIR)/usr/lib/systemd/system/rpcbind.socket
        mkdir -p $(TARGET_DIR)/etc/systemd/system/sockets.target.wants
        ln -fs ../../../../usr/lib/systemd/system/rpcbind.socket \