package/sdl: remove qtopia video driver option
authorPeter Korsgaard <peter@korsgaard.com>
Wed, 6 Feb 2019 14:10:46 +0000 (15:10 +0100)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Wed, 6 Feb 2019 14:40:10 +0000 (15:40 +0100)
The qtopia option uses the obsolete qt4 package, which we are about to
remove, to remove the qtopia option as well.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
[Arnout: move the enable-qtopia=no option to the beginning]
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Config.in.legacy
package/sdl/Config.in
package/sdl/sdl.mk

index 5a330cada96402da25c692f3c8a18eb464bc10b0..0eb69361cc84a08592da43e214bc8c073d6c1319 100644 (file)
@@ -146,6 +146,12 @@ endif
 
 comment "Legacy options removed in 2019.02"
 
+config BR2_PACKAGE_SDL_QTOPIA
+       bool "sdl qtopia video driver option removed"
+       select BR2_LEGACY
+       help
+         The SDL QTopia video driver option was removed.
+
 config BR2_PACKAGE_PYTHON_PYQT
        bool "python-pyqt package removed"
        select BR2_LEGACY
index 65ac8a246924e70e086e4900137915f9677bd19d..9f1e34de5c78666a3af29375ff26df5f1923b0bc 100644 (file)
@@ -17,10 +17,6 @@ config BR2_PACKAGE_SDL_DIRECTFB
        bool "SDL DirectFB video driver"
        depends on BR2_PACKAGE_DIRECTFB
 
-config BR2_PACKAGE_SDL_QTOPIA
-       bool "SDL Qtopia video driver"
-       depends on BR2_PACKAGE_QT
-
 config BR2_PACKAGE_SDL_X11
        bool "SDL X11 video driver"
        depends on BR2_PACKAGE_XORG7
index 0a6a7de1390940513ea4c2f8610c8fa830f3b4ce..06564d610a5cf2d5ce4a4e40e134c78122cda688 100644 (file)
@@ -23,6 +23,8 @@ HOST_SDL_PRE_CONFIGURE_HOOKS += SDL_RUN_AUTOGEN
 SDL_DEPENDENCIES += host-automake host-autoconf host-libtool
 HOST_SDL_DEPENDENCIES += host-automake host-autoconf host-libtool
 
+SDL_CONF_OPTS += --enable-video-qtopia=no
+
 ifeq ($(BR2_PACKAGE_SDL_FBCON),y)
 SDL_CONF_OPTS += --enable-video-fbcon=yes
 else
@@ -37,13 +39,6 @@ else
 SDL_CONF_OPTS += --enable-video-directfb=no
 endif
 
-ifeq ($(BR2_PACKAGE_SDL_QTOPIA),y)
-SDL_CONF_OPTS += --enable-video-qtopia=yes
-SDL_DEPENDENCIES += qt
-else
-SDL_CONF_OPTS += --enable-video-qtopia=no
-endif
-
 ifeq ($(BR2_PACKAGE_SDL_X11),y)
 SDL_CONF_OPTS += --enable-video-x11=yes
 SDL_DEPENDENCIES += \