package/snappy: add dependency on host-pkgconf
authorSteve James <ste@junkomatic.net>
Wed, 17 Dec 2014 12:25:59 +0000 (12:25 +0000)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 18 Dec 2014 21:59:57 +0000 (22:59 +0100)
Snappy doesn't configure without host pkg-config, causing this totally
unhelpful diagnostic from autoconf:

  configure.ac:42: error: possibly undefined macro: AC_DEFINE
        If this token and others are legitimate, please use m4_pattern_allow.
        See the Autoconf documentation.
  configure.ac:44: error: possibly undefined macro: AC_MSG_FAILURE

So add host-pkgconf to the package's DEPENDENCIES list.

Signed-off-by: Steve James <ste@junkomatic.net>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/snappy/snappy.mk

index fd89325af8c81c7f4eb4663eb91f9ba69abe6256..6bda7ce854bd043bda88806fb73aabe5de63e8db 100644 (file)
@@ -10,6 +10,7 @@ SNAPPY_LICENSE = BSD-3c
 SNAPPY_LICENSE_FILES = COPYING
 # from git
 SNAPPY_AUTORECONF = YES
+SNAPPY_DEPENDENCIES = host-pkgconf
 SNAPPY_INSTALL_STAGING = YES
 
 $(eval $(autotools-package))