sdl2: explicitly disable raspberry pi video backend
authorPeter Korsgaard <peter@korsgaard.com>
Wed, 25 Oct 2017 16:03:26 +0000 (18:03 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 26 Oct 2017 12:08:55 +0000 (14:08 +0200)
Fixes:
http://autobuild.buildroot.net/results/d59/d5992dcc9a49ee77afaebdcc9448ac1868fa7de1/
http://autobuild.buildroot.net/results/e89/e894f21ce1983ee3bd8d65a8e59e1adab9a62707/

The configure script automatically enables support for the raspberry pi
video backend if it detects the rpi-userland package.  Unfortunately it
hardcodes a number of include/linker paths unsuitable for cross compilation,
breaking the build:

    if test x$enable_video = xyes -a x$enable_video_rpi = xyes; then
..
     RPI_CFLAGS="-I/opt/vc/include -I/opt/vc/include/interface/vcos/pthreads -I/opt/vc/include/interface/vmcs_host/linux"
     RPI_LDFLAGS="-L/opt/vc/lib -lbcm_host"
    fi

So explicitly disable it until the configure script is fixed.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/sdl2/sdl2.mk

index facb41e52705da75fccf915dce49087fa0e4886e..fa3b57e6cd4642fc23b209c1ae971da00f770e2d 100644 (file)
@@ -18,7 +18,8 @@ SDL2_CONF_OPTS += \
        --disable-esd \
        --disable-dbus \
        --disable-pulseaudio \
-       --disable-video-wayland
+       --disable-video-wayland \
+       --disable-video-rpi
 
 # We must enable static build to get compilation successful.
 SDL2_CONF_OPTS += --enable-static