package/pulseaudio: explicitly enable/disable WebRTC support
authorRomain Naour <romain.naour@gmail.com>
Sun, 3 Jul 2016 23:35:05 +0000 (01:35 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 4 Jul 2016 15:15:33 +0000 (17:15 +0200)
Currently, pulseaudio optionally depends on webrtc if it is enabled.

However, it is never explcitly enabled or disabled, although
pulseaudio's ./configure has --enable/disable-webrtc-aec.

Forcibly enable/disable webrtc support using those options.

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/pulseaudio/pulseaudio.mk

index bc95d915519e61b0eb9a5ff8013b320eedc50d65..9ef11bc019f3b474dd2f55e93979abeccdd6d756 100644 (file)
@@ -34,7 +34,6 @@ PULSEAUDIO_DEPENDENCIES = \
        $(if $(BR2_PACKAGE_BLUEZ_UTILS),bluez_utils) \
        $(if $(BR2_PACKAGE_OPENSSL),openssl) \
        $(if $(BR2_PACKAGE_FFTW),fftw) \
-       $(if $(BR2_PACKAGE_WEBRTC_AUDIO_PROCESSING),webrtc-audio-processing) \
        $(if $(BR2_PACKAGE_SYSTEMD),systemd)
 
 ifeq ($(BR2_PACKAGE_GDBM),y)
@@ -88,6 +87,13 @@ else
 PULSEAUDIO_CONF_OPTS += --disable-udev
 endif
 
+ifeq ($(BR2_PACKAGE_WEBRTC_AUDIO_PROCESSING),y)
+PULSEAUDIO_CONF_OPTS += --enable-webrtc-aec
+PULSEAUDIO_DEPENDENCIES += webrtc-audio-processing
+else
+PULSEAUDIO_CONF_OPTS += --disable-webrtc-aec
+endif
+
 ifneq ($(BR2_INSTALL_LIBSTDCPP),y)
 # The optional webrtc echo canceller is written in C++, causing auto* to want
 # to link module-echo-cancel.so with CXX even if webrtc ISN'T used.