package/libselinux: enable kernel selinux support for ubifs images
authorAdam Duskett <Aduskett@gmail.com>
Fri, 31 Jul 2020 20:41:00 +0000 (13:41 -0700)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 4 Sep 2020 13:43:54 +0000 (15:43 +0200)
If BR2_TARGET_ROOTFS_UBIFS is selected, enable the following kernel options:
  - CONFIG_UBIFS_FS_XATTR
  - CONFIG_UBIFS_FS_SECURITY

Signed-off-by: Adam Duskett <Aduskett@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/libselinux/libselinux.mk

index f2c29221228fcd32e442c1f309db31c8cc559c40..c96b5a4431096d6c8ccb07c296abe502e5d388d1 100644 (file)
@@ -129,6 +129,9 @@ define LIBSELINUX_LINUX_CONFIG_FIXUPS
                $(call KCONFIG_ENABLE_OPT,CONFIG_JFS_SECURITY))
        $(if $(BR2_TARGET_ROOTFS_SQUASHFS),
                $(call KCONFIG_ENABLE_OPT,CONFIG_SQUASHFS_XATTR))
+       $(if $(BR2_TARGET_ROOTFS_UBIFS),
+               $(call KCONFIG_ENABLE_OPT,CONFIG_UBIFS_FS_XATTR)
+               $(call KCONFIG_ENABLE_OPT,CONFIG_UBIFS_FS_SECURITY))
 endef
 
 $(eval $(generic-package))