package/duma: do not let Makefile guess OS
authorYann E. MORIN <yann.morin.1998@free.fr>
Sat, 17 May 2014 17:34:50 +0000 (19:34 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 17 May 2014 21:29:20 +0000 (23:29 +0200)
We need to tell the duma Makefile what OS we're gonna run on, or it
uses default values.

It turns out the default values are the same as for OS=linux (and so
this change should be a no-op), but it's just better to force it, and
it avoids a warning during the build.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/duma/duma.mk

index d11987f4afde6495a4bf21be8cabbca4ca4d66d7..6e730f9766b311c94b050c08cb080be3e04aae65 100644 (file)
@@ -19,6 +19,7 @@ DUMA_OPTIONS = \
 # build time, is not specified in the Makefile. Force non-parallel build.
 define DUMA_BUILD_CMDS
        $(MAKE1) $(TARGET_CONFIGURE_OPTS)       \
+               OS=linux \
                DUMA_OPTIONS="$(DUMA_OPTIONS)"   \
                $(DUMA_CPP) -C $(@D)
 endef