lshw: use the new gettext logic
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 3 Jul 2017 20:57:18 +0000 (22:57 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 4 Jul 2017 23:28:45 +0000 (01:28 +0200)
This commit switches to use the new gettext logic, which involves:

 - using TARGET_NLS_DEPENDENCIES instead of hand-encoded dependencies
   on gettext/host-gettext

 - using TARGET_NLS_LIBS to force linking against libintl

 - dropping BR2_PACKAGE_GETTEXT selection

 - using BR2_SYSTEM_ENABLE_NLS instead of BR2_ENABLE_LOCALE to decide
   whether NLS support is enabled or not

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/lshw/Config.in
package/lshw/lshw.mk

index 8cc935ab4d2e25d3ca559b8e646bccb366ae482e..83b7ffb72bd4224a664ec8d8b0115fb0b87a62a6 100644 (file)
@@ -2,7 +2,6 @@ config BR2_PACKAGE_LSHW
        bool "lshw"
        depends on BR2_INSTALL_LIBSTDCPP
        depends on BR2_USE_WCHAR
-       select BR2_PACKAGE_GETTEXT if BR2_NEEDS_GETTEXT_IF_LOCALE
        help
          lshw (Hardware Lister) is a small tool to provide
          detailed information on the hardware configuration of the machine.
index eb396117f116aaae0ec11f40c8a8222b83a70e15..43b937b920097fd07a523eab3c59b4dc87afce51 100644 (file)
@@ -10,7 +10,7 @@ LSHW_LICENSE = GPL-2.0
 LSHW_LICENSE_FILES = COPYING
 
 LSHW_CFLAGS = $(TARGET_CFLAGS)
-ifeq ($(BR2_ENABLE_LOCALE),)
+ifeq ($(BR2_SYSTEM_ENABLE_NLS),)
 LSHW_CFLAGS += -DNONLS
 endif
 
@@ -18,8 +18,8 @@ LSHW_MAKE_OPTS = CC="$(TARGET_CC)" CXX="$(TARGET_CXX)" AR="$(TARGET_AR)" \
        RPM_OPT_FLAGS="$(LSHW_CFLAGS)" all
 LSHW_MAKE_ENV = \
        $(TARGET_MAKE_ENV) \
-       LIBS="$(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),-lintl)"
-LSHW_DEPENDENCIES = $(if $(BR2_NEEDS_GETTEXT_IF_LOCALE),gettext)
+       LIBS=$(TARGET_NLS_LIBS)
+LSHW_DEPENDENCIES = $(TARGET_NLS_DEPENDENCIES)
 
 define LSHW_BUILD_CMDS
        $(LSHW_MAKE_ENV) $(MAKE) -C $(@D)/src $(LSHW_MAKE_OPTS)