Makefile: remove pkg-stats data on clean
authorYann E. MORIN <yann.morin.1998@free.fr>
Tue, 18 May 2021 20:28:17 +0000 (22:28 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Tue, 18 May 2021 20:31:25 +0000 (22:31 +0200)
Like commit 1f187371d002 for cpe-updates data, also remove pkg-stats
data on clean.

Unlike the rest, those are not nicely located in a directory of their
own, and have no variable name associated with them, so we just need
to repeat their names in the clean rule.

Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Cc: Matthew Weber <matthew.weber@rockwellcollins.com>
Reviewed-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Makefile

index c3305f46e90a242bb876c81d0548dab39d6ac175..9d2c0d8ecbdc6214b84eb48426cafc4990b11f55 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -1089,7 +1089,8 @@ printvars:
 clean:
        rm -rf $(BASE_TARGET_DIR) $(BINARIES_DIR) $(HOST_DIR) $(HOST_DIR_SYMLINK) \
                $(BUILD_DIR) $(BASE_DIR)/staging \
-               $(LEGAL_INFO_DIR) $(GRAPHS_DIR) $(PER_PACKAGE_DIR) $(CPE_UPDATES_DIR)
+               $(LEGAL_INFO_DIR) $(GRAPHS_DIR) $(PER_PACKAGE_DIR) $(CPE_UPDATES_DIR) \
+               $(O)/pkg-stats.*
 
 .PHONY: distclean
 distclean: clean