package/linux-tools: add iio
authorMarcin Niestroj <m.niestroj@grinn-global.com>
Tue, 4 Oct 2016 16:01:39 +0000 (18:01 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 5 Oct 2016 20:57:54 +0000 (22:57 +0200)
Signed-off-by: Marcin Niestroj <m.niestroj@grinn-global.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/linux-tools/Config.in
package/linux-tools/linux-tool-iio.mk [new file with mode: 0644]

index bd07509f0f7c68d77339fba3e17867f3225b38bc..db9ed9f19be54c929edff7eabdd5b5684cc65e1a 100644 (file)
@@ -32,6 +32,15 @@ config BR2_PACKAGE_LINUX_TOOLS_GPIO
 
          These tools are available only from kernel version 4.8.
 
+config BR2_PACKAGE_LINUX_TOOLS_IIO
+       bool "iio"
+       select BR2_PACKAGE_LINUX_TOOLS
+       help
+         iio is a collection of tools to get information about,
+         control and monitor iio devices present on system.
+
+         These tools are available only from kernel version 4.7.
+
 config BR2_PACKAGE_LINUX_TOOLS_PERF
        bool "perf"
        select BR2_PACKAGE_LINUX_TOOLS
diff --git a/package/linux-tools/linux-tool-iio.mk b/package/linux-tools/linux-tool-iio.mk
new file mode 100644 (file)
index 0000000..60d6249
--- /dev/null
@@ -0,0 +1,27 @@
+################################################################################
+#
+# iio
+#
+################################################################################
+
+LINUX_TOOLS += iio
+
+IIO_MAKE_OPTS = $(LINUX_MAKE_FLAGS)
+
+define IIO_BUILD_CMDS
+       $(Q)if ! grep install $(LINUX_DIR)/tools/iio/Makefile >/dev/null 2>&1 ; then \
+               echo "Your kernel version is too old and does not have install section in the iio tools." ; \
+               echo "At least kernel 4.7 must be used." ; \
+               exit 1 ; \
+       fi
+
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(LINUX_DIR)/tools/iio \
+               $(IIO_MAKE_OPTS)
+endef
+
+define IIO_INSTALL_TARGET_CMDS
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(LINUX_DIR)/tools/iio \
+               $(IIO_MAKE_OPTS) \
+               INSTALL_ROOT=$(TARGET_DIR) \
+               install
+endef