- forgot to put base-target's sources into the source target.
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Tue, 18 Sep 2007 13:12:25 +0000 (13:12 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Tue, 18 Sep 2007 13:12:25 +0000 (13:12 -0000)
  Thanks to Ulf for pointing out this error of mine..

Makefile

index e029cfd680d598fbe811a7f1fccc2ce03404fd70..717bb7b64f5175f10bc6511a758ebcc881509f8c 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -216,8 +216,7 @@ include target/Makefile.in
 TARGETS+=erase-fakeroots
 
 TARGETS_CLEAN:=$(patsubst %,%-clean,$(TARGETS))
-TARGETS_SOURCE:=$(patsubst %,%-source,$(TARGETS))
-BASE_TARGETS_SOURCE:=$(patsubst %,%-source,$(BASE_TARGETS))
+TARGETS_SOURCE:=$(patsubst %,%-source,$(TARGETS) $(BASE_TARGETS))
 TARGETS_DIRCLEAN:=$(patsubst %,%-dirclean,$(TARGETS))
 TARGETS_ALL:=$(patsubst %,__real_tgt_%,$(TARGETS))
 # all targets depend on the crosscompiler and it's prerequisites
@@ -284,7 +283,7 @@ $(TARGET_DIR): $(PROJECT_BUILD_DIR)/.root
 erase-fakeroots:
        rm -f $(PROJECT_BUILD_DIR)/.fakeroot*
 
-source: $(BASE_TARGETS_SOURCE) $(TARGETS_SOURCE) $(HOST_SOURCE)
+source: $(TARGETS_SOURCE) $(HOST_SOURCE)
 
 _source-check:
        $(MAKE) SPIDER=--spider source