libimxvpuapi: bump to version 0.10.3
authorDanomi Manchego <danomimanchego123@gmail.com>
Thu, 23 Feb 2017 02:43:39 +0000 (21:43 -0500)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 23 Feb 2017 20:46:09 +0000 (21:46 +0100)
Because with libimxvpuapi older than 0.10.3, the gst1-imx-0.12.3 "imxvpu"
plugin will not build.

Changelog:
* properly pass on color format in simplified JPEG encoder interface
* add alternative write-callback-style encoding mode
  also add encode example variant which uses write-callback style output
* add support for "fake grayscale mode" in encoders
  this is done by using I420 internally and filling the U and V planes
  with 0x80 bytes
* make sure JPEG quantization table is copied in standardized zig zag order
  the VPU does not, so this has to be done explicitely

Signed-off-by: Danomi Manchego <danomimanchego123@gmail.com>
Reviewed-by: Gary Bisson <gary.bisson@boundarydevices.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/libimxvpuapi/libimxvpuapi.hash
package/libimxvpuapi/libimxvpuapi.mk

index c8cabcf285d4b8607e881a31ed337279469386f7..cd0c8f1f5f934ff64148f6b3f417834a34234353 100644 (file)
@@ -1,2 +1,2 @@
 # locally computed hash
-sha256 8e6dc4105db6164c0de72fd60eb73f4ba1632f7ba5052b1abc834b462b566da2  libimxvpuapi-0.10.2.tar.gz
+sha256 7151e10a24929935bada1d3d87626f17e411575b3a4ac0d86440999ad0100a55  libimxvpuapi-0.10.3.tar.gz
index fde44293755ac3ef846dcb6289a6ae6365181001..d368d3d064e59434f78b8a5a1890bdb10a199b5f 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-LIBIMXVPUAPI_VERSION = 0.10.2
+LIBIMXVPUAPI_VERSION = 0.10.3
 LIBIMXVPUAPI_SITE = $(call github,Freescale,libimxvpuapi,$(LIBIMXVPUAPI_VERSION))
 LIBIMXVPUAPI_LICENSE = LGPLv2.1+
 LIBIMXVPUAPI_LICENSE_FILES = LICENSE