ffmpeg: Add ffprobe option
authorSteve Kenton <skenton@ou.edu>
Tue, 2 Dec 2014 00:55:35 +0000 (18:55 -0600)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 3 Dec 2014 22:20:37 +0000 (23:20 +0100)
Signed-off-by Stephen M. Kenton <skenton@ou.edu>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/ffmpeg/Config.in
package/ffmpeg/ffmpeg.mk

index 6fde46edb5060594267be01e11b64189010accde..5f86f52c36209f14b548313bae86bbc010fd1c4b 100644 (file)
@@ -49,6 +49,12 @@ config BR2_PACKAGE_FFMPEG_FFSERVER
        help
          FFserver is a streaming server for both audio and video.
 
+config BR2_PACKAGE_FFMPEG_FFPROBE
+       bool "Build ffprobe"
+       help
+         FFprobe is a utility to determine the audio and video
+         characteristics of a container file.
+
 config BR2_PACKAGE_FFMPEG_AVRESAMPLE
        bool "Build libavresample"
        help
index 22577e63787831adb5fb681de2682619f1c7449e..784d8b356721280cc89770f702571add4e0d2ee1 100644 (file)
@@ -23,7 +23,6 @@ FFMPEG_CONF_OPTS = \
        --enable-logging \
        --enable-optimizations \
        --disable-extra-warnings \
-       --disable-ffprobe \
        --enable-avdevice \
        --enable-avcodec \
        --enable-avformat \
@@ -104,6 +103,12 @@ else
 FFMPEG_CONF_OPTS += --disable-avresample
 endif
 
+ifeq ($(BR2_PACKAGE_FFMPEG_FFPROBE),y)
+FFMPEG_CONF_OPTS += --enable-ffprobe
+else
+FFMPEG_CONF_OPTS += --disable-ffprobe
+endif
+
 ifeq ($(BR2_PACKAGE_FFMPEG_POSTPROC),y)
 FFMPEG_CONF_OPTS += --enable-postproc
 else