projects
/
buildroot.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
fde7a19
)
libssh2: fix static linking issue with libgcrypt
author
Peter Korsgaard
<peter@korsgaard.com>
Tue, 18 Nov 2014 14:31:33 +0000
(15:31 +0100)
committer
Peter Korsgaard
<peter@korsgaard.com>
Tue, 18 Nov 2014 14:31:33 +0000
(15:31 +0100)
Fixes:
http://autobuild.buildroot.net/results/07e/
07e50ba575b305b37e7a94a773c2b2e255393e9f
/
http://autobuild.buildroot.net/results/072/
07249f0a001a34ae608a8f8646b26a1152219252
/
http://autobuild.buildroot.net/results/1c0/
1c0447431e4c025732ea2eb8e9788e303f24fd04
/
http://autobuild.buildroot.net/results/5e1/
5e1f58c086e437b85b0d31310a93a3b2d0d70836
/
And many more.
libgcrypt depends on libgpg-error and the configure script forgets to link
against it breaking static linking. Fix it by using libgcrypt-config
--libs.
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libssh2/libssh2.mk
patch
|
blob
|
history
diff --git
a/package/libssh2/libssh2.mk
b/package/libssh2/libssh2.mk
index 67064ebc5768977f65474f8b11092ed690feaf42..c9f7059bc1ef85e0f47d161d149aa299381ff401 100644
(file)
--- a/
package/libssh2/libssh2.mk
+++ b/
package/libssh2/libssh2.mk
@@
-18,6
+18,9
@@
LIBSSH2_DEPENDENCIES += libgcrypt
LIBSSH2_CONF_OPTS += --with-libgcrypt \
--with-libgcrypt-prefix=$(STAGING_DIR)/usr \
--without-openssl
+# configure.ac forgets to link to dependent libraries of gcrypt breaking static
+# linking
+LIBSSH2_CONF_ENV += LIBS="$(shell $(STAGING_DIR)/usr/bin/libgcrypt-config --libs)"
else
LIBSSH2_DEPENDENCIES += openssl
LIBSSH2_CONF_OPTS += --with-openssl \