package/vlc: sort VLC_CONF_OPTS
authorBernd Kuhls <bernd.kuhls@t-online.de>
Sun, 12 Aug 2018 20:29:14 +0000 (22:29 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 16 Aug 2018 09:59:30 +0000 (11:59 +0200)
No code changes. The upcoming bump to vlc 3.0.3 will add another eleven
--disable-* options to CONF_OPTS. To stay on top of things we sort the
current entries before we begin the version bump.

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/vlc/vlc.mk

index af85377c94741d191e648b5491a9de37ff2dbbf4..5e5230edc9e698799095b50a27e245f7bb0a13fc 100644 (file)
@@ -34,33 +34,33 @@ endef
 VLC_POST_PATCH_HOOKS += VLC_OVERRIDE_PKG_M4
 
 VLC_CONF_OPTS += \
-       --disable-gles1 \
        --disable-a52 \
-       --disable-shout \
-       --disable-twolame \
-       --disable-dca \
-       --disable-schroedinger \
-       --disable-fluidsynth \
-       --disable-zvbi \
-       --disable-kate \
+       --disable-addonmanagermodules \
        --disable-caca \
-       --disable-jack \
-       --disable-samplerate \
        --disable-chromaprint \
+       --disable-dca \
+       --disable-dvdnav \
+       --disable-fluidsynth \
+       --disable-gles1 \
        --disable-goom \
-       --disable-projectm \
-       --disable-vsxu \
-       --disable-mtp \
+       --disable-jack \
+       --disable-jpeg \
+       --disable-kate \
+       --disable-mfx \
        --disable-mmal-codec \
        --disable-mmal-vout \
-       --disable-dvdnav \
+       --disable-mtp \
+       --disable-projectm \
+       --disable-samplerate \
+       --disable-schroedinger \
+       --disable-shout \
+       --disable-twolame \
+       --disable-vdpau \
        --disable-vpx \
-       --disable-jpeg \
+       --disable-vsxu \
        --disable-x262 \
        --disable-x265 \
-       --disable-mfx \
-       --disable-vdpau \
-       --disable-addonmanagermodules \
+       --disable-zvbi \
        --enable-run-as-root
 
 # Uses __atomic_fetch_add_4