package/cegui: disable ogre support
authorBartosz Bilas <b.bilas@grinn-global.com>
Mon, 27 Apr 2020 20:09:09 +0000 (22:09 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Mon, 27 Apr 2020 20:11:33 +0000 (22:11 +0200)
Buildroot's ogre version isn't compatible with current (v0-8-7) cegui
therefore disable support for that. It will be restored when upstream will
switch to the new version.

Fixes:
  - http://autobuild.buildroot.net/results/8ee717ac4d596fc0af274037841ac4ed6862ddaa/

Signed-off-by: Bartosz Bilas <b.bilas@grinn-global.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/cegui/cegui.mk

index 434201b1f8e68ab2689fc3959c40b00be0e5e99f..673340194a5aec045bfe679823de193f3fa82df8 100644 (file)
@@ -10,7 +10,8 @@ CEGUI_LICENSE = MIT
 CEGUI_LICENSE_FILES = COPYING
 CEGUI_INSTALL_STAGING = YES
 CEGUI_CONF_OPTS += -DCEGUI_BUILD_XMLPARSER_XERCES=OFF \
-                  -DCEGUI_HAS_MINIZIP_RESOURCE_PROVIDER=OFF
+                  -DCEGUI_HAS_MINIZIP_RESOURCE_PROVIDER=OFF \
+                  -DCEGUI_BUILD_RENDERER_OGRE=OFF
 CEGUI_DEPENDENCIES = glm \
                $(if $(BR2_PACKAGE_LIBGLFW),libglfw) \
                $(if $(BR2_PACKAGE_HAS_LIBGL),libgl) \
@@ -25,13 +26,6 @@ else
 CEGUI_CONF_OPTS += -DCEGUI_USE_EPOXY=OFF
 endif
 
-ifeq ($(BR2_PACKAGE_OGRE),y)
-CEGUI_DEPENDENCIES += ogre
-CEGUI_CONF_OPTS += -DCEGUI_BUILD_RENDERER_OGRE=ON
-else
-CEGUI_CONF_OPTS += -DCEGUI_BUILD_RENDERER_OGRE=OFF
-endif
-
 ifeq ($(BR2_PACKAGE_EXPAT),y)
 CEGUI_DEPENDENCIES += expat
 CEGUI_CONF_OPTS += -DCEGUI_BUILD_XMLPARSER_EXPAT=ON