target: remove BR2_TARGET_ROOTFS_*_SQUASH options
authorPeter Korsgaard <jacmet@sunsite.dk>
Tue, 7 Apr 2009 19:22:37 +0000 (19:22 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 7 Apr 2009 19:22:37 +0000 (19:22 -0000)
Everything besides ubifs does an unconditional chown -R 0:0 anyway.

target/jffs2/Config.in
target/jffs2/jffs2root.mk
target/ubifs/Config.in
target/ubifs/ubifsroot.mk

index 2a4c48cf7d85570c1ab50128602183ea586bd67c..d6a8f059b3effb479a81848bee8447793b6b1846 100644 (file)
@@ -113,10 +113,6 @@ config BR2_TARGET_ROOTFS_JFFS2_BE
 
 endchoice
 
-config BR2_TARGET_ROOTFS_JFFS2_SQUASH
-       bool "Make all files be owned by root"
-       depends on BR2_TARGET_ROOTFS_JFFS2
-
 config BR2_TARGET_ROOTFS_JFFS2_SUMMARY
        bool "Produce a summarized JFFS2 image"
        depends on BR2_TARGET_ROOTFS_JFFS2
index 94c6c30390e0e58059f246d9e0620e097a364ba7..1e03bf04675196ab23a1ef02703342446cb9de28 100644 (file)
@@ -16,10 +16,6 @@ endif
 SUMTOOL_OPTS += -p
 endif
 
-ifeq ($(BR2_TARGET_ROOTFS_JFFS2_SQUASH),y)
-JFFS2_OPTS += -q
-endif
-
 ifeq ($(BR2_TARGET_ROOTFS_JFFS2_LE),y)
 JFFS2_OPTS += -l
 SUMTOOL_OPTS += -l
index 85229f61ca6f77188d4607c0065a910287bde0c6..90ebfd9e4ff3f9904eb9ea149b8958ef3c5ec30c 100644 (file)
@@ -23,11 +23,6 @@ config BR2_TARGET_ROOTFS_UBIFS_MAXLEBCNT
        help
          Some comment required here
 
-config BR2_TARGET_ROOTFS_UBIFS_SQUASH
-       bool "Make all files be owned by root"
-       depends on  BR2_TARGET_ROOTFS_UBIFS
-       default y
-
 config BR2_TARGET_ROOTFS_UBIFS_OUTPUT
        string "Output File"
        depends on BR2_TARGET_ROOTFS_UBIFS
index cd330df0108edcc936f0fc8dc346f08832616aba..2f3e96505ed7130360996d6150c490a5e3a0bc84 100644 (file)
@@ -93,9 +93,7 @@ endif
        rm -f $(PROJECT_BUILD_DIR)/_fakeroot.$(notdir $(UBIFS_TARGET))
        touch $(PROJECT_BUILD_DIR)/.fakeroot.00000
        cat $(PROJECT_BUILD_DIR)/.fakeroot* > $(PROJECT_BUILD_DIR)/_fakeroot.$(notdir $(UBIFS_TARGET))
-ifneq ($(BR2_TARGET_ROOTFS_UBIFS_SQUASH),)
        echo "chown -R 0:0 $(TARGET_DIR)" >> $(PROJECT_BUILD_DIR)/_fakeroot.$(notdir $(UBIFS_TARGET))
-endif
 ifneq ($(TARGET_DEVICE_TABLE),)
        # Use fakeroot to pretend to create all needed device nodes
        echo "$(HOST_DIR)/usr/bin/makedevs -d $(TARGET_DEVICE_TABLE) $(TARGET_DIR)" \