boot/beaglev-ddrlnit: rename to beaglev-ddrinit to match renamed upstream repo
authorPeter Korsgaard <peter@korsgaard.com>
Mon, 10 May 2021 09:06:57 +0000 (11:06 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 10 May 2021 20:04:38 +0000 (22:04 +0200)
And adjust DEVELOPERS and beaglev_defconfig to match.

The typo in the repo name has now been fixed:

https://github.com/starfive-tech/beagle_ddrinit/issues/6

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
DEVELOPERS
boot/beaglev-ddrinit/Config.in [new file with mode: 0644]
boot/beaglev-ddrinit/beaglev-ddrinit.hash [new file with mode: 0644]
boot/beaglev-ddrinit/beaglev-ddrinit.mk [new file with mode: 0644]
boot/beaglev-ddrlnit/Config.in [deleted file]
boot/beaglev-ddrlnit/beaglev-ddrlnit.hash [deleted file]
boot/beaglev-ddrlnit/beaglev-ddrlnit.mk [deleted file]
configs/beaglev_defconfig

index bbbb0ecfa83a8439d09997a33229d0144a1eeafd..b688c8a8c16297df3bac3afbb1ff463ce753a471 100644 (file)
@@ -2604,7 +2604,7 @@ N:        Thomas Petazzoni <thomas.petazzoni@bootlin.com>
 F:     arch/Config.in.arm
 F:     board/beaglev/
 F:     board/stmicroelectronics/stm32mp157c-dk2/
-F:     boot/beaglev-ddrlnit/
+F:     boot/beaglev-ddrinit/
 F:     boot/beaglev-secondboot/
 F:     boot/boot-wrapper-aarch64/
 F:     boot/grub2/
diff --git a/boot/beaglev-ddrinit/Config.in b/boot/beaglev-ddrinit/Config.in
new file mode 100644 (file)
index 0000000..7ca92a7
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_TARGET_BEAGLEV_DDRINIT
+       bool "beaglev-ddrinit"
+       depends on BR2_riscv
+       depends on BR2_HOSTARCH = "x86_64" # host-riscv64-elf-toolchain
+       help
+         This package builds the DDRinit firmware used on the BeagleV
+         platform.
+
+         https://github.com/starfive-tech/beagle_ddrinit
diff --git a/boot/beaglev-ddrinit/beaglev-ddrinit.hash b/boot/beaglev-ddrinit/beaglev-ddrinit.hash
new file mode 100644 (file)
index 0000000..5bbbe28
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally computed
+sha256  0809b72e1e8e40f82acdcfd4c8a6a120e14bd9ed395592e075bb54acc8c07271  beaglev-ddrinit-15b80de81263996affb2a29332aa681925709983.tar.gz
diff --git a/boot/beaglev-ddrinit/beaglev-ddrinit.mk b/boot/beaglev-ddrinit/beaglev-ddrinit.mk
new file mode 100644 (file)
index 0000000..02df061
--- /dev/null
@@ -0,0 +1,29 @@
+################################################################################
+#
+# beaglev-ddrinit
+#
+################################################################################
+
+# Commit on the 'starfive' branch
+BEAGLEV_DDRINIT_VERSION = 15b80de81263996affb2a29332aa681925709983
+BEAGLEV_DDRINIT_SITE = $(call github,starfive-tech,beagle_ddrinit,$(BEAGLEV_DDRINIT_VERSION))
+BEAGLEV_DDRINIT_INSTALL_TARGET = NO
+BEAGLEV_DDRINIT_INSTALL_IMAGES = YES
+BEAGLEV_DDRINIT_DEPENDENCIES = host-riscv64-elf-toolchain
+# unfortunately, no real license file, but several sources files are
+# under GPL-2.0+, making the whole work GPL-2.0+
+BEAGLEV_DDRINIT_LICENSE = GPL-2.0+
+
+define BEAGLEV_DDRINIT_BUILD_CMDS
+       $(MAKE) -C $(@D)/build \
+               CROSSCOMPILE=$(HOST_DIR)/bin/riscv64-unknown-elf- \
+               SUFFIX=buildroot \
+               GIT_VERSION=$(BEAGLEV_DDRINIT_VERSION)
+endef
+
+define BEAGLEV_DDRINIT_INSTALL_IMAGES_CMDS
+       $(INSTALL) -D -m 0644 $(@D)/build/ddrinit-2133-buildroot.bin.out \
+               $(BINARIES_DIR)/ddrinit-2133-buildroot.bin.out
+endef
+
+$(eval $(generic-package))
diff --git a/boot/beaglev-ddrlnit/Config.in b/boot/beaglev-ddrlnit/Config.in
deleted file mode 100644 (file)
index e9d6e08..0000000
+++ /dev/null
@@ -1,9 +0,0 @@
-config BR2_TARGET_BEAGLEV_DDRLNIT
-       bool "beaglev-ddrlnit"
-       depends on BR2_riscv
-       depends on BR2_HOSTARCH = "x86_64" # host-riscv64-elf-toolchain
-       help
-         This package builds the DDRinit firmware used on the BeagleV
-         platform.
-
-         https://github.com/starfive-tech/beagle_ddrlnit
diff --git a/boot/beaglev-ddrlnit/beaglev-ddrlnit.hash b/boot/beaglev-ddrlnit/beaglev-ddrlnit.hash
deleted file mode 100644 (file)
index fe699b0..0000000
+++ /dev/null
@@ -1,2 +0,0 @@
-# Locally computed
-sha256  dee7f8003ee02d7799d07b598dd5823e10b42f50fae6135b2320a8d7e1fa77bf  beaglev-ddrlnit-15b80de81263996affb2a29332aa681925709983.tar.gz
diff --git a/boot/beaglev-ddrlnit/beaglev-ddrlnit.mk b/boot/beaglev-ddrlnit/beaglev-ddrlnit.mk
deleted file mode 100644 (file)
index 042878f..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-################################################################################
-#
-# beaglev-ddrlnit
-#
-################################################################################
-
-# Commit on the 'starfive' branch
-BEAGLEV_DDRLNIT_VERSION = 15b80de81263996affb2a29332aa681925709983
-BEAGLEV_DDRLNIT_SITE = $(call github,starfive-tech,beagle_ddrlnit,$(BEAGLEV_DDRLNIT_VERSION))
-BEAGLEV_DDRLNIT_INSTALL_TARGET = NO
-BEAGLEV_DDRLNIT_INSTALL_IMAGES = YES
-BEAGLEV_DDRLNIT_DEPENDENCIES = host-riscv64-elf-toolchain
-# unfortunately, no real license file, but several sources files are
-# under GPL-2.0+, making the whole work GPL-2.0+
-BEAGLEV_DDRLNIT_LICENSE = GPL-2.0+
-
-define BEAGLEV_DDRLNIT_BUILD_CMDS
-       $(MAKE) -C $(@D)/build \
-               CROSSCOMPILE=$(HOST_DIR)/bin/riscv64-unknown-elf- \
-               SUFFIX=buildroot \
-               GIT_VERSION=$(BEAGLEV_DDRLNIT_VERSION)
-endef
-
-define BEAGLEV_DDRLNIT_INSTALL_IMAGES_CMDS
-       $(INSTALL) -D -m 0644 $(@D)/build/ddrinit-2133-buildroot.bin.out \
-               $(BINARIES_DIR)/ddrinit-2133-buildroot.bin.out
-endef
-
-$(eval $(generic-package))
index 59051e7a6d9c8473f7278d33d92d1b621c1ee2f8..8943ce9c340b971c61d5a47494f191491e75d3f6 100644 (file)
@@ -18,7 +18,7 @@ BR2_LINUX_KERNEL_INSTALL_TARGET=y
 BR2_TARGET_ROOTFS_EXT2=y
 BR2_TARGET_ROOTFS_EXT2_4=y
 # BR2_TARGET_ROOTFS_TAR is not set
-BR2_TARGET_BEAGLEV_DDRLNIT=y
+BR2_TARGET_BEAGLEV_DDRINIT=y
 BR2_TARGET_BEAGLEV_SECONDBOOT=y
 BR2_TARGET_OPENSBI=y
 BR2_TARGET_OPENSBI_CUSTOM_TARBALL=y