lvm2: prevent dmsetup from being re-installed every time
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 21 Feb 2010 14:55:43 +0000 (15:55 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Tue, 23 Feb 2010 19:34:55 +0000 (20:34 +0100)
After being copied to target/, touch dmsetup so that its date is newer
than the .built stamp file in lvm2 source directory. This prevents
make from re-installing dmsetup every time.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/lvm2/lvm2.mk

index d190be2f039e1cf91ee91317705091e1d18f0124..bc6f458720a84d900034088b217ea45529291afa 100644 (file)
@@ -86,9 +86,11 @@ $(LVM2_DIR)/.built: $(LVM2_DIR)/.configured
 
 $(LVM2_TARGET_SBINS) $(LVM2_TARGET_DMSETUP_SBINS): $(LVM2_DIR)/.built
        cp -a $(STAGING_DIR)/sbin/$(notdir $@) $@
+       touch $@
 
 $(LVM2_TARGET_LIBS): $(LVM2_DIR)/.built
        cp -a $(STAGING_DIR)/lib/$(notdir $@) $@
+       touch $@
 
 
 ifeq ($(BR2_PACKAGE_LVM2_DMSETUP_ONLY),y)