<pkg>-rsync: exclude version control files
authorThomas De Schampheleire <patrickdepinguin+buildroot@gmail.com>
Fri, 1 Mar 2013 10:26:38 +0000 (10:26 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 17 Mar 2013 13:40:23 +0000 (14:40 +0100)
When using rsync to import package sources (typically with
PKG_OVERRIDE_SRCDIR), it often happens that these external sources
are under version control, and contain directories like .git,
.hg, etc.

Depending on the project, these directories can become pretty large
and typically have a lot of files. Moreover, they are not necessary
in the context of building the package. Therefore, this commit adds
the --cvs-exclude option to the rsync call, saving both disk space
and sync time.

Signed-off-by: Thomas De Schampheleire <thomas.de.schampheleire@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/pkg-generic.mk

index 57b0fd08c1ba1357c52a5f285ba49ed7764e49ae..8d964a18c10cbb76a8ea013429dd6ad4e4efd196 100644 (file)
@@ -62,7 +62,7 @@ $(BUILD_DIR)/%/.stamp_extracted:
 $(BUILD_DIR)/%/.stamp_rsynced:
        @$(call MESSAGE,"Syncing from source dir $(SRCDIR)")
        @test -d $(SRCDIR) || (echo "ERROR: $(SRCDIR) does not exist" ; exit 1)
-       rsync -au $(SRCDIR)/ $(@D)
+       rsync -au --cvs-exclude $(SRCDIR)/ $(@D)
        $(Q)touch $@
 
 # Handle the SOURCE_CHECK and SHOW_EXTERNAL_DEPS cases for rsynced