package/opencv3: fix build with gcc bug 64735
authorBernd Kuhls <bernd.kuhls@t-online.de>
Wed, 1 Aug 2018 20:55:28 +0000 (22:55 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 5 Aug 2018 12:16:14 +0000 (14:16 +0200)
OpenCV3 allows to disable the usage of std::exception_ptr:
https://github.com/opencv/opencv/issues/11878#issuecomment-402099255

Fixes
http://autobuild.buildroot.net/results/5ca/5ca221792c72c0a19f8b0e8303c0603d28f3c48e/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/opencv3/opencv3.mk

index 09455d61b2334c15f2dd25a0d78eb59030277d07..ea4d22743f19e64dcfb468f758988c87666734b2 100644 (file)
@@ -11,13 +11,21 @@ OPENCV3_LICENSE = BSD-3-Clause
 OPENCV3_LICENSE_FILES = LICENSE
 OPENCV3_SUPPORTS_IN_SOURCE_BUILD = NO
 
+OPENCV3_CXXFLAGS = $(TARGET_CXXFLAGS)
+
 # Uses __atomic_fetch_add_4
 ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)
-OPENCV3_CONF_OPTS += -DCMAKE_CXX_FLAGS="$(TARGET_CXXFLAGS) -latomic"
+OPENCV3_CXXFLAGS += -latomic
+endif
+
+# Fix c++11 build with missing std::exception_ptr
+ifeq ($(BR2_TOOLCHAIN_HAS_GCC_BUG_64735),y)
+OPENCV3_CXXFLAGS += -DCV__EXCEPTION_PTR=0
 endif
 
 # OpenCV component options
 OPENCV3_CONF_OPTS += \
+       -DCMAKE_CXX_FLAGS="$(OPENCV3_CXXFLAGS)" \
        -DBUILD_DOCS=OFF \
        -DBUILD_PERF_TESTS=$(if $(BR2_PACKAGE_OPENCV3_BUILD_PERF_TESTS),ON,OFF) \
        -DBUILD_TESTS=$(if $(BR2_PACKAGE_OPENCV3_BUILD_TESTS),ON,OFF) \