sdl: fix incorrect SDL_CONF_OPTS assignment
authorRodrigo Rebello <rprebello@gmail.com>
Wed, 21 Oct 2015 03:10:25 +0000 (01:10 -0200)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 21 Oct 2015 08:07:21 +0000 (10:07 +0200)
The option --enable-video-directfb=no was being assigned to
SDL_CONF_OPTS instead of being appended to it when
BR2_PACKAGE_SDL_DIRECTFB was disabled. That would clobber any options
previously added to SDL_CONF_OPTS (namely --enable-video-fbcon=yes|no).

Signed-off-by: Rodrigo Rebello <rprebello@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/sdl/sdl.mk

index 05d9a547015273c35b2c94f6c27d2f446639a6fc..78eb4ddd8dbd9aa6a5fafdee17a2167638d89c7d 100644 (file)
@@ -34,7 +34,7 @@ SDL_DEPENDENCIES += directfb
 SDL_CONF_OPTS += --enable-video-directfb=yes
 SDL_CONF_ENV = ac_cv_path_DIRECTFBCONFIG=$(STAGING_DIR)/usr/bin/directfb-config
 else
-SDL_CONF_OPTS = --enable-video-directfb=no
+SDL_CONF_OPTS += --enable-video-directfb=no
 endif
 
 ifeq ($(BR2_PACKAGE_SDL_QTOPIA),y)