replace github with GitHub
authorSimon Dawson <spdawson@gmail.com>
Mon, 2 Jun 2014 15:55:59 +0000 (16:55 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 4 Jun 2014 21:14:08 +0000 (23:14 +0200)
The correct capitalisation pattern is "GitHub"; fix manual and makefile
commentary.

Signed-off-by: Simon Dawson <spdawson@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
docs/manual/adding-packages-generic.txt
docs/manual/adding-packages-tips.txt
package/e2tools/e2tools.mk
package/libsha1/libsha1.mk
package/pkg-download.mk
package/smack/smack.mk

index d3fa45b0105e267c37c2cb68dc8cd746fccef0d0..67a74536596533cc2aedc5d7d73d39524728b9e5 100644 (file)
@@ -228,7 +228,7 @@ information is (assuming the package name is +libfoo+) :
   types for retrieving package tarballs. Git, Subversion, Mercurial,
   and Bazaar are supported URL types for retrieving packages directly
   from source code management systems. There is a helper function to make
-  it easier to download source tarballs from github (refer to
+  it easier to download source tarballs from GitHub (refer to
   xref:github-download-url[] for details). A filesystem path may be used
   to specify either a tarball or a directory containing the package
   source code. See +LIBFOO_SITE_METHOD+ below for more details on how
index 9266af6755df1e9d9627f84472b38f663095156b..0d4fcb062756b84cab9fc6a76c49609673ed386e 100644 (file)
@@ -34,11 +34,11 @@ using the following rules:
 
 
 [[github-download-url]]
-==== How to add a package from github
+==== How to add a package from GitHub
 
-Packages on github often don't have a download area with release tarballs.
+Packages on GitHub often don't have a download area with release tarballs.
 However, it is possible to download tarballs directly from the repository
-on github. As github is known to have changed download mechanisms in the
+on GitHub. As GitHub is known to have changed download mechanisms in the
 past, the 'github' helper function should be used as shown below.
 
 ------------------------
index 97afcc0746fdfa68c7fa3bb71f10438b55f96bd4..789519fe8d4fd1176bc3654ff8bbe66ebd0829da 100644 (file)
@@ -7,7 +7,7 @@
 E2TOOLS_VERSION = 3158ef18a903ca4a98b8fa220c9fc5c133d8bdf6
 E2TOOLS_SITE = $(call github,ndim,e2tools,$(E2TOOLS_VERSION))
 
-# Source coming from github, no configure included.
+# Source coming from GitHub, no configure included.
 E2TOOLS_AUTORECONF = YES
 E2TOOLS_LICENSE = GPLv2
 E2TOOLS_LICENSE_FILES = COPYING
index 2fd7705a1e0c62e8a470aae268d93a2e7c8c7127..647f986d4fa336ef9e99ac00c4b9fabb14e4353f 100644 (file)
@@ -11,7 +11,7 @@ LIBSHA1_LICENSE_FILES = COPYING
 
 LIBSHA1_INSTALL_STAGING = YES
 
-# We're getting the source code from Github, so there is no generated
+# We're getting the source code from GitHub, so there is no generated
 # configure script in the tarball.
 LIBSHA1_AUTORECONF = YES
 
index 192b9e03315a51be534b7170ddb8f6878bc336c0..4cfb913b926b1b215f39a765a888309462d7caaa 100644 (file)
@@ -55,7 +55,7 @@ notdomain=$(patsubst $(call domain,$(1),$(2))$(call domainseparator,$(2))%,%,$(c
 # default domainseparator is /, specify alternative value as first argument
 domainseparator=$(if $(1),$(1),/)
 
-# github(user,package,version): returns site of github repository
+# github(user,package,version): returns site of GitHub repository
 github = https://github.com/$(1)/$(2)/archive/$(3)
 
 ################################################################################
index af6e81c92bc4ddec2a169db62f4a21fd4a70bbb0..7e0a362c9fca9450c6500457c3caf549a16ff35b 100644 (file)
@@ -11,7 +11,7 @@ SMACK_LICENSE_FILES = COPYING
 SMACK_INSTALL_STAGING = YES
 SMACK_DEPENDENCIES = host-pkgconf
 
-# Sources from github, no configure script included.
+# Sources from GitHub, no configure script included.
 SMACK_AUTORECONF = YES
 
 $(eval $(autotools-package))