boost: bump to version 1.52.0
authorVictor Hiairrassary <victor.hiairrassary.ml@gmail.com>
Tue, 11 Dec 2012 21:50:11 +0000 (21:50 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 12 Dec 2012 08:54:50 +0000 (09:54 +0100)
[Peter: merge largefile comment with C++ one]
Signed-off-by: Victor Hiairrassary <victor.hiairrassary.ml@gmail.com>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tested-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
 (x86_64 Sourcery toolchain)
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/boost/Config.in
package/boost/boost.mk

index 87983676ead5ed8641db8812772bae906d4393a2..fb5360ecf4c19081585f75302f458e722ec5cbb9 100644 (file)
@@ -1,9 +1,10 @@
-comment "boost requires a toolchain with C++ support enabled"
-       depends on !BR2_INSTALL_LIBSTDCPP
+comment "boost requires a toolchain with C++ and large file support enabled"
+       depends on !BR2_INSTALL_LIBSTDCPP || !BR2_LARGEFILE
 
 config BR2_PACKAGE_BOOST
        bool "boost"
        depends on BR2_INSTALL_LIBSTDCPP
+       depends on BR2_LARGEFILE
        select BR2_PACKAGE_BZIP2
        select BR2_PACKAGE_ZLIB
        help
index 64856bc6dc8e6c708db1e233cf4d2af769687fe4..005c7ca7542f1597fb340766e9e6c4ba4a70e1f0 100644 (file)
@@ -4,7 +4,7 @@
 #
 #############################################################
 
-BOOST_VERSION = 1.49.0
+BOOST_VERSION = 1.52.0
 BOOST_FILE_VERSION = $(subst .,_,$(BOOST_VERSION))
 BOOST_SOURCE = boost_$(BOOST_FILE_VERSION).tar.bz2
 BOOST_SITE = http://downloads.sourceforge.net/project/boost/boost/$(BOOST_VERSION)
@@ -15,7 +15,7 @@ TARGET_CC_VERSION = $(shell $(TARGET_CC) -dumpversion)
 BOOST_DEPENDENCIES = bzip2 zlib
 
 BOOST_FLAGS =
-BOOST_WITHOUT_FLAGS = python
+BOOST_WITHOUT_FLAGS = python context
 
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_CHRONO),,chrono)
 BOOST_WITHOUT_FLAGS += $(if $(BR2_PACKAGE_BOOST_DATE_TIME),,date_time)