linux: drop LDFLAGS override
authorMike Frysinger <vapier@gentoo.org>
Wed, 17 Nov 2010 09:11:18 +0000 (04:11 -0500)
committerPeter Korsgaard <jacmet@sunsite.dk>
Tue, 7 Dec 2010 22:01:35 +0000 (23:01 +0100)
The current linux code overrides LDFLAGS that the kernel itself might be
setting up. Looking at the history, there doesn't seem to be any reason
for this override. It was added in ea8b1fa6a60705 without any logic.

Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
linux/linux.mk

index 8dc7dd07ff4ad89f37beadfb55bd0d6044d86120..feda4182cce213409c006de5533f889ee1e062cd 100644 (file)
@@ -24,7 +24,6 @@ LINUX26_MAKE_FLAGS = \
        ARCH=$(KERNEL_ARCH) \
        INSTALL_MOD_PATH=$(TARGET_DIR) \
        CROSS_COMPILE=$(TARGET_CROSS) \
-       LDFLAGS="$(TARGET_LDFLAGS)" \
        LZMA="$(LZMA)"
 
 # Get the real Linux version, which tells us where kernel modules are