kexec-lite: Depends on elfutils instead of libelf to get the libelf library
authorGregory CLEMENT <gregory.clement@free-electrons.com>
Thu, 28 Aug 2014 12:21:33 +0000 (14:21 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 13 Sep 2014 22:03:18 +0000 (00:03 +0200)
The elfutils package provides a more recent version of the libelf, so
let's use it. It will allow to remove the libelf package and to avoid
conflicts with two packages providing the same library.

[Peter: adjust toolchain options comment to match]
Signed-off-by: Gregory CLEMENT <gregory.clement@free-electrons.com>
Acked-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/kexec-lite/Config.in
package/kexec-lite/kexec-lite.mk

index 944ee29e967dfb5005fead4912d8894b7d25af36..e98ad3ab9642a46e635ced3120bad6947300f05e 100644 (file)
@@ -2,7 +2,9 @@ config BR2_PACKAGE_KEXEC_LITE
        bool "kexec-lite"
        depends on BR2_powerpc || BR2_powerpc64
        depends on !BR2_PREFER_STATIC_LIB # dtc
-       select BR2_PACKAGE_LIBELF
+       depends on BR2_LARGEFILE # elfutils
+       depends on BR2_USE_WCHAR # elfutils
+       select BR2_PACKAGE_ELFUTILS
        select BR2_PACKAGE_DTC
        select BR2_PACKAGE_DTC_PROGRAMS
        help
@@ -12,6 +14,6 @@ config BR2_PACKAGE_KEXEC_LITE
          This package is a tiny implementation of the kexec userspace
          components, for devicetree-based platforms.
 
-comment "kexec-lite needs a toolchain w/ dynamic library"
+comment "kexec-lite needs a toolchain w/ largefile, wchar, dynamic library"
        depends on BR2_powerpc || BR2_powerpc64
-       depends on BR2_PREFER_STATIC_LIB
+       depends on BR2_PREFER_STATIC_LIB || !BR2_LARGEFILE || !BR2_USE_WCHAR
index 7028c6ef846281dab4821edb223df9d26b9be8bc..7e3c8d30f8ce935daa68e4a167cf699876a8dbdf 100644 (file)
@@ -7,7 +7,7 @@
 KEXEC_LITE_VERSION = fb8543fea3beb0522b5a63a74ea1a845dbd7b954
 KEXEC_LITE_SITE = $(call github,antonblanchard,kexec-lite,$(KEXEC_LITE_VERSION))
 KEXEC_LITE_LICENSE = GPLv2+
-KEXEC_LITE_DEPENDENCIES = libelf dtc
+KEXEC_LITE_DEPENDENCIES = elfutils dtc
 
 define KEXEC_LITE_BUILD_CMDS
        $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D) all