package/pcm-tools: fix build with GCC 4.8.2
authorCarlos Santos <casantos@datacom.com.br>
Sat, 15 Dec 2018 01:38:13 +0000 (23:38 -0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 16 Dec 2018 15:26:51 +0000 (16:26 +0100)
Add "-std=c++11" to CXXFLAGS, forcing C++ 2011 standard (it's
experimental in GCC 4.8.2 but goot enough to build pcm-tools).

Fixes:

  http://autobuild.buildroot.net/results/cf3c79f0c94be8a184d532570bdb1893090316a3/

Signed-off-by: Carlos Santos <casantos@datacom.com.br>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/pcm-tools/pcm-tools.mk

index c0d6d8bc526db95ccc82b9aa3da623c92c953e76..6d5938f94e4d7afa98421847d305bc1bd1c7760f 100644 (file)
@@ -16,6 +16,7 @@ PCM_TOOLS_EXE_FILES = \
 define PCM_TOOLS_BUILD_CMDS
        touch $(@D)/daemon-binaries
        $(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D) \
+               CXXFLAGS="$(TARGET_CXXFLAGS) -std=c++11" \
                UNAME=Linux HOST=_LINUX
 endef