iptables: use correct variable for configure options
authorPeter Korsgaard <jacmet@sunsite.dk>
Mon, 30 Mar 2009 18:42:02 +0000 (18:42 -0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 30 Mar 2009 18:42:02 +0000 (18:42 -0000)
Introduced in r23409.

package/iptables/iptables.mk

index 21ea5be138e2f1d300da68bbc1b8ce250d8ec351..f18dd9e9fe540db1275178780afdee92a133c6fc 100644 (file)
@@ -7,7 +7,7 @@ IPTABLES_VERSION = 1.4.2
 IPTABLES_SOURCE = iptables-$(IPTABLES_VERSION).tar.bz2
 IPTABLES_SITE = http://ftp.netfilter.org/pub/iptables
 
-IPTABLES_CONF_OPT = --libexecdir=/usr/lib
+IPTABLES_CONF_OPT = --libexecdir=/usr/lib --with-kernel=$(LINUX_HEADERS_DIR)
 ifneq ($(BR2_INET_IPV6),y)
 IPTABLES_CONF_OPT += --enable-ipv6=no
 endif
@@ -16,7 +16,6 @@ IPTABLES_INSTALL_TARGET = YES
 
 IPTABLES_AUTORECONF = YES
 IPTABLES_DEPENDENCIES =
-IPTABLES_CONFIGURE_OPT = --with-kernel=$(LINUX_HEADERS_DIR)
 
 $(eval $(call AUTOTARGETS,package,iptables))