cups: disable php extension
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 16 Dec 2013 18:58:19 +0000 (15:58 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 16 Dec 2013 20:41:11 +0000 (21:41 +0100)
Such an old cups version isn't compatible with newer PHP series, so just
disable it. Fixes:
http://autobuild.buildroot.net/results/2dc/2dc985fc7cff6bd5d20fc074db4f6f7997dd81f5/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/cups/cups.mk

index 8a761a32a9fe1ddb2d9d0d211cf89e15772e620e..bcd6f1e01c5a4ca8c62f70e3a3d6e4227e6c37ea 100644 (file)
@@ -14,6 +14,7 @@ CUPS_INSTALL_STAGING_OPT = DESTDIR=$(STAGING_DIR) DSTROOT=$(STAGING_DIR) install
 CUPS_INSTALL_TARGET_OPT = DESTDIR=$(TARGET_DIR) DSTROOT=$(TARGET_DIR) install
 CUPS_CONF_OPT = --without-perl \
                --without-java \
+               --without-php \
                --disable-gnutls \
                --disable-gssapi \
                --libdir=/usr/lib
@@ -35,14 +36,6 @@ ifeq ($(BR2_PACKAGE_XORG7),y)
        CUPS_DEPENDENCIES += xlib_libX11
 endif
 
-ifeq ($(BR2_PACKAGE_PHP),y)
-       CUPS_CONF_ENV += ac_cv_path_PHPCONFIG=$(STAGING_DIR)/usr/bin/php-config
-       CUPS_CONF_OPT += --with-php
-       CUPS_DEPENDENCIES += php
-else
-       CUPS_CONF_OPT += --without-php
-endif
-
 ifeq ($(BR2_PACKAGE_PYTHON),y)
        CUPS_CONF_OPT += --with-python
        CUPS_DEPENDENCIES += python