package/Makefile.in: Fix dependency for selecting uclinux as TARGET_OS
authorAxel Lin <axel.lin@ingics.com>
Mon, 23 Sep 2013 09:16:50 +0000 (17:16 +0800)
committerPeter Korsgaard <peter@korsgaard.com>
Sun, 12 Oct 2014 12:58:54 +0000 (14:58 +0200)
Current setting only allows blackfin to select uclinux as TARGET_OS.
However, some noMMU ARM platforms that using FLAT binary format also need to
select uclinux as TARGET_OS. Fix the dependency.

Signed-off-by: Axel Lin <axel.lin@ingics.com>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/Makefile.in

index 7d9943c1c003f258a23a3398be090c7377ff814c..28a5bfdfcf9afde354181b434e3d6d5bb66bdfd8 100644 (file)
@@ -38,8 +38,8 @@ endif
 # Compute GNU_TARGET_NAME
 GNU_TARGET_NAME = $(ARCH)-$(TARGET_VENDOR)-$(TARGET_OS)-$(LIBC)$(ABI)
 
-# Blackfin FLAT needs uclinux
-ifeq ($(BR2_bfin)$(BR2_BINFMT_FLAT),yy)
+# FLAT binary format needs uclinux
+ifeq ($(BR2_BINFMT_FLAT),y)
 TARGET_OS = uclinux
 else
 TARGET_OS = linux