weston: add DRM compoitor support
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 29 Mar 2016 14:39:02 +0000 (11:39 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 30 Mar 2016 14:59:11 +0000 (16:59 +0200)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/weston/Config.in
package/weston/weston.mk

index aaf1706c1b13e91c671d989e18dd024d3cf23abe..8cefa411b4217f009fcce01ed44020065130ea6e 100644 (file)
@@ -37,6 +37,16 @@ if BR2_PACKAGE_WESTON
 config BR2_PACKAGE_WESTON_HAS_COMPOSITOR
        bool
 
+config BR2_PACKAGE_WESTON_DRM
+       bool "DRM compositor"
+       depends on BR2_PACKAGE_MESA3D_OPENGL_EGL
+       select BR2_PACKAGE_LIBDRM
+       select BR2_PACKAGE_WESTON_HAS_COMPOSITOR
+
+# Uses libgbm from mesa3d
+comment "DRM compositor needs an OpenGL EGL backend provided by mesa3d"
+       depends on !BR2_PACKAGE_MESA3D_OPENGL_EGL
+
 config BR2_PACKAGE_WESTON_FBDEV
        bool "fbdev compositor"
 
index 5af23dfab4d0d4b8c4b0443f2bd4801b81e5ad3d..d600bc330b0d3e6f4d7f1363c58657791dd767bb 100644 (file)
@@ -18,7 +18,6 @@ WESTON_CONF_OPTS = \
        --disable-simple-egl-clients \
        --disable-xwayland \
        --disable-x11-compositor \
-       --disable-drm-compositor \
        --disable-wayland-compositor \
        --disable-headless-compositor \
        --disable-weston-launch \
@@ -56,6 +55,15 @@ else
 WESTON_CONF_OPTS += --disable-fbdev-compositor
 endif
 
+ifeq ($(BR2_PACKAGE_WESTON_DRM),y)
+WESTON_CONF_OPTS += \
+       --enable-drm-compositor \
+       WESTON_NATIVE_BACKEND=drm-backend.so
+WESTON_DEPENDENCIES += libdrm
+else
+WESTON_CONF_OPTS += --disable-drm-compositor
+endif
+
 ifeq ($(BR2_PACKAGE_WESTON_RPI),y)
 WESTON_DEPENDENCIES += rpi-userland
 WESTON_CONF_OPTS += --enable-rpi-compositor \