perl-net-ssh2: avoid build system inspecting host paths
authorThomas De Schampheleire <thomas.de_schampheleire@nokia.com>
Mon, 23 Jul 2018 20:06:27 +0000 (22:06 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 25 Jul 2018 21:03:02 +0000 (23:03 +0200)
During investigation of adding gcrypt support in perl-net-ssh2, it became
clear that its build system is trying to find libraries via host search
paths, i.e. /usr/lib64/ etc.

This can be avoided by explicitly passing a 'lib' and 'inc' path.

Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/perl-net-ssh2/perl-net-ssh2.mk

index b174fa62108980b872ebc3da716c81a48fd171df..77d39edef5b62c57206410c8c14a3d46c6425088 100644 (file)
@@ -10,5 +10,9 @@ PERL_NET_SSH2_SITE = $(BR2_CPAN_MIRROR)/authors/id/S/SA/SALVA
 PERL_NET_SSH2_LICENSE = Artistic or GPL-1.0+
 PERL_NET_SSH2_LICENSE_FILES = README
 PERL_NET_SSH2_DEPENDENCIES = libssh2 zlib
+# build system will use host search paths by default
+PERL_NET_SSH2_CONF_OPTS += \
+       lib="$(STAGING_DIR)/usr/lib" \
+       inc="$(STAGING_DIR)/usr/include"
 
 $(eval $(perl-package))