s6-dns: new package
authorEric Le Bihan <eric.le.bihan.dev@free.fr>
Mon, 19 Dec 2016 21:29:10 +0000 (22:29 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 9 Mar 2017 22:07:29 +0000 (23:07 +0100)
This new package provides s6-dns, a suite of DNS client programs and
libraries for Unix systems, as an alternative to the BIND, djbdns or
other DNS clients.

Signed-off-by: Eric Le Bihan <eric.le.bihan.dev@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
DEVELOPERS
package/Config.in
package/s6-dns/Config.in [new file with mode: 0644]
package/s6-dns/s6-dns.hash [new file with mode: 0644]
package/s6-dns/s6-dns.mk [new file with mode: 0644]

index 73413eb47d4657704598d39cff14229bdd23e54e..f67d4160908e779061900e8546b3cb67c18df802 100644 (file)
@@ -441,6 +441,7 @@ F:  package/hicolor-icon-theme/
 F:     package/jemalloc/
 F:     package/ninja/
 F:     package/s6/
+F:     package/s6-dns/
 F:     package/skalibs/
 F:     package/smack/
 F:     package/xvisor/
index 1cb584ca1dfed7cfabdeaf6ca9c600bbf9b8c7a9..bca190cadd2a13564f0c89c57fc6a71df13f9cce 100644 (file)
@@ -1640,6 +1640,7 @@ endif
        source "package/rsync/Config.in"
        source "package/rtorrent/Config.in"
        source "package/rtptools/Config.in"
+       source "package/s6-dns/Config.in"
        source "package/samba4/Config.in"
        source "package/sconeserver/Config.in"
        source "package/ser2net/Config.in"
diff --git a/package/s6-dns/Config.in b/package/s6-dns/Config.in
new file mode 100644 (file)
index 0000000..75917f9
--- /dev/null
@@ -0,0 +1,10 @@
+config BR2_PACKAGE_S6_DNS
+       bool "s6-dns"
+       select BR2_PACKAGE_SKALIBS
+       depends on BR2_USE_MMU # skalibs
+       help
+         s6-dns is a suite of DNS client programs and libraries for
+         Unix systems, as an alternative to the BIND, djbdns or other
+         DNS clients.
+
+         http://skarnet.org/software/s6-dns/
diff --git a/package/s6-dns/s6-dns.hash b/package/s6-dns/s6-dns.hash
new file mode 100644 (file)
index 0000000..7cfb9c3
--- /dev/null
@@ -0,0 +1,2 @@
+# Locally generated
+sha256 8455f3b1edad8f01a1340cb1242c141755729bfd5d71059739eced5c006539ad s6-dns-2.1.0.0.tar.gz
diff --git a/package/s6-dns/s6-dns.mk b/package/s6-dns/s6-dns.mk
new file mode 100644 (file)
index 0000000..d77956f
--- /dev/null
@@ -0,0 +1,45 @@
+################################################################################
+#
+# s6-dns
+#
+################################################################################
+
+S6_DNS_VERSION = 2.1.0.0
+S6_DNS_SITE = http://skarnet.org/software/s6-dns
+S6_DNS_LICENSE = ISC
+S6_DNS_LICENSE_FILES = COPYING
+S6_DNS_INSTALL_STAGING = YES
+S6_DNS_DEPENDENCIES = skalibs
+
+S6_DNS_CONF_OPTS = \
+       --prefix=/usr \
+       --with-sysdeps=$(STAGING_DIR)/usr/lib/skalibs/sysdeps \
+       --with-include=$(STAGING_DIR)/usr/include \
+       --with-dynlib=$(STAGING_DIR)/usr/lib \
+       --with-lib=$(STAGING_DIR)/usr/lib/skalibs \
+       $(if $(BR2_STATIC_LIBS),,--disable-allstatic) \
+       $(SHARED_STATIC_LIBS_OPTS)
+
+define S6_DNS_CONFIGURE_CMDS
+       (cd $(@D); $(TARGET_CONFIGURE_OPTS) ./configure $(S6_DNS_CONF_OPTS))
+endef
+
+define S6_DNS_BUILD_CMDS
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D)
+endef
+
+define S6_DNS_REMOVE_STATIC_LIB_DIR
+       rm -rf $(TARGET_DIR)/usr/lib/s6-dns
+endef
+
+S6_DNS_POST_INSTALL_TARGET_HOOKS += S6_DNS_REMOVE_STATIC_LIB_DIR
+
+define S6_DNS_INSTALL_TARGET_CMDS
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) DESTDIR=$(TARGET_DIR) install
+endef
+
+define S6_DNS_INSTALL_STAGING_CMDS
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) DESTDIR=$(STAGING_DIR) install
+endef
+
+$(eval $(generic-package))