package/rpm: don't use sub-options for bzip2 and xz features
authorRomain Naour <romain.naour@openwide.fr>
Sun, 18 Jan 2015 19:53:08 +0000 (20:53 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 1 Feb 2015 22:11:54 +0000 (23:11 +0100)
Allow enabling features depends on the relying packages.

Add the old sub-options to Config.in.legacy.

Signed-off-by: Romain Naour <romain.naour@openwide.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Config.in.legacy
package/rpm/Config.in
package/rpm/rpm.mk

index a8c5dabef2d1ac1f39424b6a7ebbaa1582ff024f..0f1b2024c4c79e6bb20124e7452e460eb284578c 100644 (file)
@@ -102,6 +102,22 @@ endif
 
 comment "Legacy options removed in 2015.02"
 
+config BR2_PACKAGE_RPM_BZIP2_PAYLOADS
+       bool "rpm's bzip2 payloads option has been removed"
+       select BR2_LEGACY
+       select BR2_PACKAGE_BZIP2
+       help
+         The bzip2 payloads option rely entirely on the dependant package bzip2.
+         So, you need to select it to enable this feature.
+
+config BR2_PACKAGE_RPM_XZ_PAYLOADS
+       bool "rpm's xz payloads option has been removed"
+       select BR2_LEGACY
+       select BR2_PACKAGE_XZ
+       help
+         The xz payloads option rely entirely on the dependant package xz.
+         So, you need to select it to enable this feature.
+
 config BR2_PACKAGE_M4
        bool "m4 target package removed"
        select BR2_LEGACY
index 5ec4167fd380c00ff35bbe9c975d7fe97992742e..c6fc3b762138244d5c09edfd86c4043bc5fcfb19 100644 (file)
@@ -19,22 +19,3 @@ config BR2_PACKAGE_RPM
          The RPM package management system.
 
          http://rpm5.org
-
-if BR2_PACKAGE_RPM
-
-config BR2_PACKAGE_RPM_BZIP2_PAYLOADS
-       bool "support for bzip2 payloads"
-       select BR2_PACKAGE_BZIP2
-       help
-         Support for bzip2 payloads in RPM.
-
-config BR2_PACKAGE_RPM_XZ_PAYLOADS
-       bool "support for xz payloads"
-       depends on BR2_INSTALL_LIBSTDCPP
-       help
-         Support for xz payloads in RPM.
-
-comment "xz payload support needs a toolchain w/ C++"
-       depends on !BR2_INSTALL_LIBSTDCPP
-
-endif
index 74f5b888e7eeba1f6301c7f333ab298e52d330b0..68d964afc8e20b9102f22655785ba34fccb7747d 100644 (file)
@@ -44,11 +44,12 @@ else
 RPM_CONF_OPTS += --with-file=no
 endif
 
-ifeq ($(BR2_PACKAGE_RPM_XZ_PAYLOADS),y)
+# xz payload support needs a toolchain w/ C++
+ifeq ($(BR2_PACKAGE_XZ)$(BR2_INSTALL_LIBSTDCPP),yy)
 RPM_CONF_OPTS += --with-xz
 endif
 
-ifeq ($(BR2_PACKAGE_RPM_BZIP2_PAYLOADS),y)
+ifeq ($(BR2_PACKAGE_BZIP2),y)
 RPM_CONF_OPTS += --with-bzip2
 RPM_DEPENDENCIES += bzip2
 endif