package/unbound: fix detection of libexpat
authorYann E. MORIN <yann.morin.1998@free.fr>
Sun, 5 Apr 2020 08:22:03 +0000 (10:22 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 5 Apr 2020 14:25:43 +0000 (16:25 +0200)
unbound open-codes the detection of libexpat, and as all packages doing
so, look in host paths (/usr/local /opt/local /usr/lib /usr/pkg /usr/sfw
/usr). Obviously this is wrong for cross-compilation.

Do for libexpat as we do for openssl, and point unbound to staging dir,
when we know expat is.

Fixes:
    http://autobuild.buildroot.org/results/a89ea6aa1cd8c253b1260ea227fea3dc9b095fe8/

Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Cc: Stefan Ott <stefan@ott.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/unbound/unbound.mk

index 937165eca7982ad97fad715797f86faeff4e0f7f..59543438fd19ff869c8e04de2ccfb78f040db24c 100644 (file)
@@ -16,6 +16,7 @@ UNBOUND_CONF_OPTS = \
        --with-pidfile=/var/run/unbound.pid \
        --with-rootkey-file=/etc/unbound/root.key \
        --enable-tfo-server \
+       --with-libexpat=$(STAGING_DIR)/usr \
        --with-ssl=$(STAGING_DIR)/usr
 
 # uClibc-ng does not have MSG_FASTOPEN