Add support for BUILDROOT_DL_DIR environment variable, overriding DL_DIR
authorUlf Samuelsson <ulf.samuelsson@atmel.com>
Sun, 19 Aug 2007 23:32:33 +0000 (23:32 -0000)
committerUlf Samuelsson <ulf.samuelsson@atmel.com>
Sun, 19 Aug 2007 23:32:33 +0000 (23:32 -0000)
Makefile
docs/buildroot.html

index b9e4cd2642b145b9c31cba24b6b25f21a2e93a03..c1df6a303977dfb04bbe94f1a9951ee974087678 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -37,6 +37,9 @@ noconfig_targets := menuconfig config oldconfig randconfig \
 ifeq ($(filter $(noconfig_targets),$(MAKECMDGOALS)),)
 -include $(TOPDIR).config
 endif
+ifneq  ($(BUILDROOT_DL_DIR),)
+BR2_DL_DIR:=$(BUILDROOT_DL_DIR)
+endif
 
 # To put more focus on warnings, be less verbose as default
 # Use 'make V=1' to see the full commands
index c496b8db4756142c9c433c4ef9515e80627efa62..4b1e9005c87197d6456dfe5ac3a49e61707bd4b5 100644 (file)
@@ -779,6 +779,28 @@ mips-linux-gcc -o foo foo.c
     toolchain and the target filesystem with exactly the same
     versions. </p>
 
+    <p>If you maintain several buildroot trees, it might be better to have
+    a shared download location. This can be accessed by creating a symbolic link
+    from the <code>dl</code> directory to the shared download location. </p>
+
+    <p>I.E:</p>
+
+<pre>
+ln -s &lt;shared download location&gt; dl
+</pre>
+
+    <p>Another way of accessing a shared download location is to
+    create the <code>BUILDROOT_DL_DIR</code> environment variable.
+    If this is set, then the value of DL_DIR in the project is
+    overridden. The following line should be added to 
+    <code>&quot;~/.bashrc&quot;</code>. <p>
+
+<pre>
+export BUILDROOT_DL_DIR &lt;shared download location&gt;
+</pre>
+
+
+
     <h2><a name="add_software" id="add_software"></a>Extending Buildroot with
     more software</h2>