links: Enable graphics for X11
authorValentine Barshak <gvaxon@gmail.com>
Mon, 15 Oct 2012 06:44:58 +0000 (06:44 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 4 Nov 2012 11:01:37 +0000 (12:01 +0100)
Graphics can be enabled for X11 as well.
Do not select DirectFB for graphics,
set DirectFB or X11 dependencies instead.

Signed-off-by: Valentine Barshak <gvaxon@gmail.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/links/Config.in
package/links/links.mk

index fddf3d26027027cd3c6ffc995b0996ee0f2f249c..474aa6a2f6e9c150fc2f5b3688f93da17b2cc91a 100644 (file)
@@ -6,10 +6,10 @@ config BR2_PACKAGE_LINKS
          http://links.twibright.com/
 
 config BR2_PACKAGE_LINKS_GRAPHICS
-       bool "use graphics (directfb)"
-       depends on BR2_PACKAGE_LINKS
-       select BR2_PACKAGE_DIRECTFB
+       bool "use graphics"
+       depends on BR2_PACKAGE_LINKS && (BR2_PACKAGE_DIRECTFB || BR2_PACKAGE_XORG7)
+       select BR2_PACKAGE_XLIB_LIBXT if BR2_PACKAGE_XORG7
        select BR2_PACKAGE_LIBPNG
        help
-         Enable graphics output.
+         Enable graphics output for DirectFB or X11.
          Otherwise links will be text-mode only.
index 4537b3a3e64be43c283dc6d8c3f751c96d06f7d5..5db2ff7e059ccb9c6d28d9aff52dddedb9d1f3ef 100644 (file)
@@ -6,13 +6,24 @@
 
 LINKS_VERSION = 2.5
 LINKS_SITE = http://links.twibright.com/download
-LINKS_CONF_OPT = --without-x
 LINKS_DEPENDENCIES = host-pkgconf
 
 ifeq ($(BR2_PACKAGE_LINKS_GRAPHICS),y)
 LINKS_CONF_OPT += --enable-graphics
+LINKS_DEPENDENCIES += libpng
+ifeq ($(BR2_PACKAGE_XLIB_LIBXT),y)
+LINKS_CONF_OPT += --with-x
+LINKS_DEPENDENCIES += xlib_libXt
+else
+LINKS_CONF_OPT += --without-x
+endif
+ifeq ($(BR2_PACKAGE_DIRECTFB),y)
 LINKS_CONF_ENV = ac_cv_path_DIRECTFB_CONFIG=$(STAGING_DIR)/usr/bin/directfb-config
-LINKS_DEPENDENCIES += directfb libpng
+LINKS_CONF_OPT += --with-directfb
+LINKS_DEPENDENCIES += directfb
+else
+LINKS_CONF_OPT += --without-directfb
+endif
 ifeq ($(BR2_PACKAGE_JPEG),y)
 LINKS_DEPENDENCIES += jpeg
 endif