doc/asciidoc: add possibility to define document dependencies
authorYann E. MORIN <yann.morin.1998@free.fr>
Sun, 17 Jul 2016 10:34:23 +0000 (12:34 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 27 Aug 2016 19:57:12 +0000 (21:57 +0200)
Currently, a document can not have dependencies, except for the purely
internal ones (like checking asciidoc version, and presence of dblatex).

For our own manual, this will come in handy when we introduce a
generated kconfig snippet, so we can actually make the manual depend on
that snippet being generated first.

For external documents, it can be used to depend on host-packages if
need be (e.g. a custom host packages that generates specific media files
included in the manual).

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Cc: Samuel Martin <s.martin49@gmail.com>
Cc: Thomas De Schampheleire <patrickdepinguin@gmail.com>
Reviewed-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
docs/manual/adding-packages-asciidoc.txt
package/doc-asciidoc.mk

index 6e2178696233e9f4b4b2ffdcaf58b19da67a73c4..0c10fd124a44250d9edfc71c3da8db5c5498ba53 100644 (file)
@@ -63,6 +63,9 @@ information is (assuming the document name is +foo+) :
   to one or more directories containing so-called resources (like CSS or
   images). By default, empty.
 
+* +FOO_DEPENDENCIES+, optional, the list of packages (most probably,
+  host-packages) that must be built before building this document.
+
 There are also additional hooks (see xref:hooks[] for general information
 on hooks), that a document may set to define extra actions to be done at
 various steps:
index 4f765b8856b0c0175957d2ef01e5c0f40545e707..cb6e61660301c72de5e26d008c589ce29c79ce4d 100644 (file)
@@ -141,7 +141,7 @@ endef
 ################################################################################
 define ASCIIDOC
 # Single line, because splitting a foreach is not easy...
-$(1)-check-dependencies: asciidoc-check-dependencies
+$(1)-check-dependencies: asciidoc-check-dependencies $$($(2)_DEPENDENCIES)
        $$(Q)$$(foreach hook,$$($(2)_CHECK_DEPENDENCIES_HOOKS),$$(call $$(hook))$$(sep))
 
 # Single line, because splitting a foreach is not easy...