dhcpcd: use standard installation
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 18 Nov 2014 17:01:56 +0000 (14:01 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 19 Nov 2014 22:15:30 +0000 (23:15 +0100)
Drop the custom/manual install cmds and do a normal make install.
This gets dhcpcd-hooks installed which are useful for many accesory
setup functions like dns, ntp server, and so on.
Also install dhcpcd to /sbin since it's expected by debian ifupdown,
For busybox ifupdown when external dhcp clients are enabled (not in the
default config we ship) will search the path.

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/dhcpcd/dhcpcd.mk

index 3bb7a135f8c9716e1d34137dd83ca96b9401bbad..975742136869d41447b011b3ada556c2aeec4139 100644 (file)
@@ -35,12 +35,7 @@ define DHCPCD_BUILD_CMDS
 endef
 
 define DHCPCD_INSTALL_TARGET_CMDS
-       $(INSTALL) -D -m 0755 $(@D)/dhcpcd \
-               $(TARGET_DIR)/usr/sbin/dhcpcd
-       $(INSTALL) -D -m 0644 $(@D)/dhcpcd.conf \
-               $(TARGET_DIR)/etc/dhcpcd.conf
-       $(INSTALL) -D -m 0755 $(@D)/dhcpcd-run-hooks \
-               $(TARGET_DIR)/libexec/dhcpcd-run-hooks
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) install DESTDIR=$(TARGET_DIR)
 endef
 
 # NOTE: Even though this package has a configure script, it is not generated