- add option to turn on SMB dump routines
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Sat, 1 Sep 2007 19:42:11 +0000 (19:42 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Sat, 1 Sep 2007 19:42:11 +0000 (19:42 -0000)
- honour BR2_INET_IPV6

package/tcpdump/Config.in
package/tcpdump/tcpdump.mk

index dbe48ba34abbc52da751f59197593cab62107eeb..63fec6c577a433aee8e43339c75191f1352471de 100644 (file)
@@ -7,6 +7,13 @@ config BR2_PACKAGE_TCPDUMP
 
          http://www.tcpdump.org/
 
+config BR2_PACKAGE_TCPDUMP_SMB
+       bool "smb dump support"
+       default n
+       depends on BR2_PACKAGE_TCPDUMP
+       help
+         enable possibly-buggy SMB printer
+
 config BR2_PACKAGE_DHCPDUMP
        bool "dhcpdump"
        default n
index 2a8dd1ef2a78827257fce11b4db543ad11631925..fcd478b6100396322a34367655466a4d0107d3b6 100644 (file)
@@ -12,6 +12,12 @@ TCPDUMP_SITE:=http://www.tcpdump.org/release
 TCPDUMP_SOURCE:=tcpdump-$(TCPDUMP_VERSION).tar.gz
 TCPDUMP_CAT:=$(ZCAT)
 
+ifneq ($(BR2_PACKAGE_TCPDUMP_SMB),y)
+TCPDUMP_ENABLE_SMB:=--disable-smb
+else
+TCPDUMP_ENABLE_SMB:=--enable-smb
+endif
+
 $(DL_DIR)/$(TCPDUMP_SOURCE):
         $(WGET) -P $(DL_DIR) $(TCPDUMP_SITE)/$(TCPDUMP_SOURCE)
 
@@ -37,7 +43,8 @@ $(TCPDUMP_DIR)/.configured: $(TCPDUMP_DIR)/.unpacked
                --mandir=/usr/share/man \
                --infodir=/usr/share/info \
                --without-crypto \
-               --disable-smb \
+               $(TCPDUMP_ENABLE_SMB) \
+               $(DISABLE_IPV6) \
        )
        $(SED) '/HAVE_PCAP_DEBUG/d' $(TCPDUMP_DIR)/config.h
        touch $@