Fix regression in Python build on 64 bits system
authorMaxime Ripard <maxime.ripard@free-electrons.com>
Mon, 29 Aug 2011 15:56:44 +0000 (17:56 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 29 Aug 2011 20:44:53 +0000 (22:44 +0200)
Commit 009d8fceab4db7815502e4b0565fe0ef531d512c introduced
--enable-shared --disable-static options for the host autotools packages,
ultimately causing a regression on the host-python build, leading to
a number of critical modules not being built on the target python on
64 bits system. Introduce a quick fix for the release and before a deeper
fix.

Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/python/python.mk

index c2839b7355b68f1702c11bfaa1065857f4319395..724fd1a928b7ee81349674a49c7c25038c5d1dca 100644 (file)
@@ -37,6 +37,19 @@ HOST_PYTHON_MAKE_ENV = \
 
 HOST_PYTHON_AUTORECONF = YES
 
+define HOST_PYTHON_CONFIGURE_CMDS
+       (cd $(@D) && rm -rf config.cache; \
+               $(HOST_CONFIGURE_OPTS) \
+               CFLAGS="$(HOST_CFLAGS)" \
+               LDFLAGS="$(HOST_LDFLAGS)" \
+                $(HOST_PYTHON_CONF_ENV) \
+               ./configure \
+               --prefix="$(HOST_DIR)/usr" \
+               --sysconfdir="$(HOST_DIR)/etc" \
+               $(HOST_PYTHON_CONF_OPT) \
+       )
+endef
+
 PYTHON_DEPENDENCIES  = host-python libffi
 
 HOST_PYTHON_DEPENDENCIES = host-expat