package/libgl: introduce as a new virtual package for full-openGL providers
authorYann E. MORIN <yann.morin.1998@free.fr>
Thu, 17 Apr 2014 16:04:22 +0000 (18:04 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 17 Apr 2014 20:59:40 +0000 (22:59 +0200)
Currently, only mesa3d is such a full-openGL provider.

But it is easy to see a few more cropping up at the door:
  - NVidia's binary blob
  - ATI's fglrx binary blob

Having this virtual full-openGL package will help when those are getting in.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Cc: Bernd Kuhls <berndkuhls@hotmail.com>
Cc: Paul Cercueil <paul@crapouillou.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/opengl/Config.in
package/opengl/libgl/Config.in [new file with mode: 0644]
package/opengl/libgl/libgl.mk [new file with mode: 0644]

index ed818353750e953efd67df423d34fda574261ecb..20ee28b06e0fa3afd64f14d21377f27518089598 100644 (file)
@@ -1,3 +1,4 @@
+source "package/opengl/libgl/Config.in"
 source "package/opengl/libegl/Config.in"
 source "package/opengl/libgles/Config.in"
 source "package/opengl/libopenvg/Config.in"
diff --git a/package/opengl/libgl/Config.in b/package/opengl/libgl/Config.in
new file mode 100644 (file)
index 0000000..8b99e5b
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_HAS_LIBGL
+       bool
+
+config BR2_PACKAGE_PROVIDES_LIBGL
+       depends on BR2_PACKAGE_HAS_LIBGL
+       string
diff --git a/package/opengl/libgl/libgl.mk b/package/opengl/libgl/libgl.mk
new file mode 100644 (file)
index 0000000..7abc13d
--- /dev/null
@@ -0,0 +1,7 @@
+################################################################################
+#
+# libgl
+#
+################################################################################
+
+$(eval $(virtual-package))