slang: forcibly disable oniguruma support
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 14 Oct 2015 21:42:18 +0000 (18:42 -0300)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 14 Oct 2015 21:48:19 +0000 (23:48 +0200)
If the host has oniguruma installed then slang can detect it and try to
(wrongly) link against it resulting in build failure. Fixes:
http://autobuild.buildroot.net/results/51f/51ff079ebbd363e0445d226ec80bc28e524fd88c/

Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/slang/slang.mk

index 59ef9932cdc588e3e16ceddcc89b189acd4628cd..1a7576afc363cbefd2a45ffc45d36c99c0993237 100644 (file)
@@ -9,6 +9,7 @@ SLANG_SITE = http://www.jedsoft.org/releases/slang
 SLANG_LICENSE = GPLv2+
 SLANG_LICENSE_FILES = COPYING
 SLANG_INSTALL_STAGING = YES
+SLANG_CONF_OPTS = --with-onig=no
 SLANG_MAKE = $(MAKE1)
 
 # Racy and we don't have/do libtermcap