boot/uboot: fix kconfig with per-package directories and host-make
authorNicolas Toromanoff <nicolas.toromanoff@foss.st.com>
Wed, 10 Mar 2021 16:16:46 +0000 (17:16 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sat, 13 Mar 2021 08:08:48 +0000 (09:08 +0100)
If PER_PACKAGE_DIRECTORIES=Y and using host-make package (because
BR2_FORCE_HOST_BUILD=Y or local make is too old) .stamp_dotconfig
target needs per-package/uboot/host/bin/host-make that doesn't
exist yet.

Add host-make into UBOOT_KCONFIG_DEPENDENCIES.

Signed-off-by: Nicolas Toromanoff <nicolas.toromanoff@foss.st.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
boot/uboot/uboot.mk

index bb4598002252a51792a34eec32f95d23cf0f2593..dbe82e65b17e6c080c4d7ab61d3d67ebf49a09be 100644 (file)
@@ -498,6 +498,7 @@ $(eval $(generic-package))
 else ifeq ($(BR2_TARGET_UBOOT_BUILD_SYSTEM_KCONFIG),y)
 UBOOT_MAKE_ENV = $(TARGET_MAKE_ENV)
 UBOOT_KCONFIG_DEPENDENCIES = \
+       $(BR2_MAKE_HOST_DEPENDENCY) \
        $(BR2_BISON_HOST_DEPENDENCY) \
        $(BR2_FLEX_HOST_DEPENDENCY)
 $(eval $(kconfig-package))