Makefile: Ensure BASE_TARGET_DIR exists, not TARGET_DIR
authorPeter Korsgaard <peter@korsgaard.com>
Sat, 31 Mar 2018 19:03:57 +0000 (21:03 +0200)
committerPeter Korsgaard <peter@korsgaard.com>
Sat, 31 Mar 2018 19:08:33 +0000 (21:08 +0200)
This was present in Yann's original patch, but got dropped when I rebased
commit 7e9870ce32 (core: introduce intermediate BASE_TARGET_DIR variable) to
fix the Makefile conflicts.

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
Makefile

index 6a3d038e6687f1026f8ad46ec3dba9532dd407d1..71c77f474d8c6972037e9c348053db90851614e3 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -945,7 +945,7 @@ savedefconfig: $(BUILD_DIR)/buildroot-config/conf prepare-kconfig
 
 # staging and target directories do NOT list these as
 # dependencies anywhere else
-$(BUILD_DIR) $(TARGET_DIR) $(HOST_DIR) $(BINARIES_DIR) $(LEGAL_INFO_DIR) $(REDIST_SOURCES_DIR_TARGET) $(REDIST_SOURCES_DIR_HOST):
+$(BUILD_DIR) $(BASE_TARGET_DIR) $(HOST_DIR) $(BINARIES_DIR) $(LEGAL_INFO_DIR) $(REDIST_SOURCES_DIR_TARGET) $(REDIST_SOURCES_DIR_HOST):
        @mkdir -p $@
 
 # outputmakefile generates a Makefile in the output directory, if using a