package/pkg-waf: use host-python3
authorTitouan Christophe <titouan.christophe@railnova.eu>
Tue, 4 Feb 2020 21:59:50 +0000 (22:59 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Sun, 3 May 2020 19:57:44 +0000 (21:57 +0200)
This is the last of an unconsolidated series of patches that
removes the need for host-python(2) for all waf-based packages.

Signed-off-by: Titouan Christophe <titouan.christophe@railnova.eu>
Reviewed-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/pkg-waf.mk

index a32d5dab33795d997b0c9f73a4f8eed26816d47f..35e56d3c138a9bc4cf4581532eabaaa38d3eedd9 100644 (file)
@@ -36,8 +36,8 @@
 
 define inner-waf-package
 
-# We need host-python to run waf
-$(2)_DEPENDENCIES += host-python
+# We need host-python3 to run waf
+$(2)_DEPENDENCIES += host-python3
 
 $(2)_NEEDS_EXTERNAL_WAF ?= NO
 
@@ -63,7 +63,7 @@ define $(2)_CONFIGURE_CMDS
        cd $$($$(PKG)_SRCDIR) && \
        $$(TARGET_CONFIGURE_OPTS) \
        $$($(2)_CONF_ENV) \
-       $$(HOST_DIR)/bin/python2 $$($(2)_WAF) configure \
+       $$(HOST_DIR)/bin/python3 $$($(2)_WAF) configure \
                --prefix=/usr \
                --libdir=/usr/lib \
                $$($(2)_CONF_OPTS) \
@@ -78,7 +78,7 @@ endif
 ifndef $(2)_BUILD_CMDS
 define $(2)_BUILD_CMDS
        cd $$($$(PKG)_SRCDIR) && \
-       $$(TARGET_MAKE_ENV) $$(HOST_DIR)/bin/python2 $$($(2)_WAF) \
+       $$(TARGET_MAKE_ENV) $$(HOST_DIR)/bin/python3 $$($(2)_WAF) \
                build -j $$(PARALLEL_JOBS) $$($(2)_BUILD_OPTS) \
                $$($(2)_WAF_OPTS)
 endef
@@ -91,7 +91,7 @@ endif
 ifndef $(2)_INSTALL_STAGING_CMDS
 define $(2)_INSTALL_STAGING_CMDS
        cd $$($$(PKG)_SRCDIR) && \
-       $$(TARGET_MAKE_ENV) $$(HOST_DIR)/bin/python2 $$($(2)_WAF) \
+       $$(TARGET_MAKE_ENV) $$(HOST_DIR)/bin/python3 $$($(2)_WAF) \
                install --destdir=$$(STAGING_DIR) \
                $$($(2)_INSTALL_STAGING_OPTS) \
                $$($(2)_WAF_OPTS)
@@ -105,7 +105,7 @@ endif
 ifndef $(2)_INSTALL_TARGET_CMDS
 define $(2)_INSTALL_TARGET_CMDS
        cd $$($$(PKG)_SRCDIR) && \
-       $$(TARGET_MAKE_ENV) $$(HOST_DIR)/bin/python2 $$($(2)_WAF) \
+       $$(TARGET_MAKE_ENV) $$(HOST_DIR)/bin/python3 $$($(2)_WAF) \
                install --destdir=$$(TARGET_DIR) \
                $$($(2)_INSTALL_TARGET_OPTS) \
                $$($(2)_WAF_OPTS)